PDA

View Full Version : Help! Help! UT4MOD isn't working!


immortius
28th May 2004, 10:49 AM
Ok, on some computers UT2k4 doesn't seem to set up Windows to recognise UT4mod files. To fix this:


Open My Computer, and then in the menu select Tools->Folder Options...
Choose the "File Types" tab.
Find the ut4mod filetype. If it doesn't exist, click new and add it.
After selecting the ut4mod filetype, click the "Advanced" button.
Give it a name and set an icon if you like.
Click "new..." to create a new action.
Name the action "Install".
For the "Application used to perform this action" box, enter:
"C:\MyUT2004InstallPath\System\setup.exe" install "%1"
(with quotes)
Ok your way back to the File Types menu. Then click "Advanced" again check to make sure the Install option is there (Tests showed windows tended to ignore the first time the option was added). If it is gone, re-add it .


And there you go (hopefully)!

Sporx
31st May 2004, 05:44 PM
when i try to create the ut4mod extension it says ( The extension '.ut4mod' is already in use by file type 'UT2004.module'. Choose another extension. )

And ya im having the problem where nothing happens when i click on the aliensawrn_v1.ut4mod extension.

Ephrom the Rabbit
31st May 2004, 06:29 PM
I did everything above too, and mine says "C:/Alienswarm/Alienswarm_v1 is not a valid windows 32" or something, do i open it with something else?

Dalai
31st May 2004, 06:58 PM
Other solutions include:

Go into your UT2004 folder and choose file -> new -> text file. Open it in Notepad and put in: "Setup.exe install AlienSwarm_v1.ut4mod". Then rename the file to "install.bat" and double click on it.
Or, as stated in the readme, use this tool to manually extract the files to your UT2004 folder, e.g. target directory is "C:\UT2004\"
http://www.acordero.org/projects/umodex/

Monki
31st May 2004, 07:00 PM
I fixed it :D

This is how I did it. Real simple and it worked for me... so maybe this'll work for everyone else.


Go to your main drive, or any folder at all on your HD. Click Tools on the menu at the top, then go to folder options. In the window that opens up click on the File Types tab.

Now scroll all the way down to the UT4MOD file type extension. Click on that, then click on the restore button. Fixed my UMOD files completely.

Tell me if this works for you. If what I have said doesn't work out, then I might have another way to get it fixed for ya.

Ephrom the Rabbit
1st Jun 2004, 02:53 PM
Okay i know have 3 folders from when i used the Umod thing.
One folder says UT2004AlienSwarm
Another on says UT2004systems
The last one says UT2004Music

These are in my UT2004 Folder and they appeared when i used the Umod.

When i run UT2004 and go to the user mods and run alien swarm this message pops up:

"UT2004 Build UT2004_Patch_[2004-05-10_17.18]

OS: Windows XP 5.1 (Build: 2600)
CPU: AuthenticAMD PentiumPro-class processor @ 1533 MHz with 255MB RAM
Video: NVIDIA GeForce2 MX 100/200 (5672)

Failed to enter AlienSwarmStartup.ut2: Can't find file 'AlienSwarmStartup.ut2'

History: UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Realloc <- 00C80008 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free <- FMallocWindows::Free"

DeepQantas
1st Jun 2004, 05:55 PM
I understand that's a problem with ut4mod installs.

You have to make sure the directory you install it to is:
C:\UT2004\

instead of:
C:\UT2004

Of course, in your case you could just rename UT2004AlienSwarm into AlienSwarm, and then move the stuff from UT2004system and UT2004Music into C:\UT2004\System and C:\UT2004\Music... altho you probably would have to delete those files manually later on if you uninstall.

[Edit: If you uninstall, not when ;) ]

Azn_Boi
2nd Jun 2004, 05:31 PM
Hi, I'm a little new to these forums but...I'm having a problem getting my game started too... :( I think this has been said already...But I just want to make sure...When I start up the game...This is what comes up...


UT2004 Build UT2004_Build_[2004-03-03_02.42]

OS: Windows XP 5.1 (Build: 2600)
CPU: GenuineIntel Unknown processor @ 1616 MHz with 511MB RAM
Video: NVIDIA GeForce FX 5200 Ultra (5216)

Failed to enter AlienSwarmStartup.ut2: Can't find file 'AlienSwarmStartup.ut2'

History: UGameEngine::Init <- InitEngine

Any ideas? Umm...Thanks :)

(Edit) Ok..I got the mod to work now...Buy when I press on Join Multiplayer...My game freezes...Anyone know what I should do? :mad:

immortius
2nd Jun 2004, 07:41 PM
Did you patch UT2004 before installing AS? If you haven't, patch UT2004 and then delete AlienSwarm.ini in UT2004/Alienswarm/System/

Alien Swarm requires the UT2004 patch for some of the mod support it introduces.

Melkinov
22nd Jun 2004, 07:32 PM
I did everything stated, but when I click it, it now says it cant find the setup.exe, what should i do?

Melkinov
22nd Jun 2004, 07:50 PM
i actually fixed that, but i have a diffrent problem. Im trying to install the game and it asks me where to install it to. So i tell it, the folder is E:\Program Files\UT2k4, which it is. But it tells me that UT2k4 is not installed there, help would be a appriciated.

immortius
20th Jul 2004, 01:24 AM
Try installing to
E:\Program Files\UT2k4\
(with that last backslash).

If that doesn't work try moving your UT directory elsewhere temporarily. like maybe to E:\UT2004.

madmerc
23rd Jul 2004, 11:10 PM
Sorry guys, but I'm stuck. I seem to have Melkinov's original problem: I followed the initial steps of altering the file type, but it says it cant find the setup.exe, it needs something to run it. Melkinov fixed it, but I can't . . .

Just out of curiosity, why is a mod so hard to install? I've patched ut2k4 to the latest, but I don't understand why a really good mod that gets a 2-page review in pcgamer is even this frustratingly difficult to get working.

immortius
24th Jul 2004, 01:07 AM
My theory is this problem is caused when someone uninstalls the UT2k4 demo after installing UT2k4, but I'm not sure. It would also be caused if you just copied UT2k4 from another computer or something. At any rate, this is the standard UT2004 mod installer (many of the mods use it). Saying that it is hard to install is silly - it is easy to install for most people, you are just unfortunately suffering a bug with your UT2004 installation. This problem was recognised from before the release of the mod, which one of the reasons why a non-umod version of the mod exists. It is also why this thread was created shortly before the mod was released too.

Double check you filetype settings, make sure that the path to setup.exe is correct (that is the setup.exe under your UT2004/system path). Make sure you have a setup.exe in your UT2004/system directory. If their is a space in the path to setup.exe, try putting it in double quotes:
"C:\Program Files\UT2004\System\Setup.exe" install "%1"

If none of this works I guess one option is to download the umod extractor listed in the readme file and manually install AlienSwarm.

madmerc
24th Jul 2004, 02:14 PM
the extractor collapses on me when i tell it to extract . . . it gets started then stops responding.

onecrazymoho
21st Aug 2004, 03:39 AM
for some reason i dont a the setup.exe file...
wtf?
i have a "setup" a "setup.est" and many many more

i tryed extracting into the AlienSwarm folder in UT2004, which i made
when i completed downloading the UMOD v. 1.1 AS file from the AS homepage i got a zip folder with 3 files. i have no idea why this isnt working. i tried all the other things, like making the ut4mod ending and stuff.

no idea why this isnt working

:mad: :P :(

and when i try use the UMODextraction tool it doesnt see the zip file
arrrgggh

*EDIT*

wait....could it be that you need the new patch for UT? oh please oh please make the damn thing work! im itching to play this mod already...

onecrazymoho
22nd Aug 2004, 02:51 AM
its not working....apparently i dont have my setup.exe file
what do i do??????
aaahhhhhhhhh

"windows cannot find the file setup.exe"
dammit...

DeepQantas
22nd Aug 2004, 08:04 AM
Well, the setup.exe it's referring to is the one in \UT2004\System\ directory.

I'm guessing it's that setup you said you had, but your windows is hiding the extensions of known filetypes.

Do you also have UT2004 instead of UT2004.exe ?

[NK]~NcWolf
14th Oct 2004, 05:44 PM
HI this is all you need to do to fix. Extract AlienSwarm-v1.2 to your UT2004 folder. Then open it and find the AlienSwarm folder. Copy JUST this folder (NOT the Music or System folders) and past the AlienSwarm folder in to the UT2004 folder next to AlienSwarm-v1.2. Now open the AlienSwarm folder and dubble click on the AlienSwarm Application file and Play...

Hope it helps
NcWolf The NutKracker Invasion server

DarkLord75
30th Jul 2005, 07:15 AM
Or you could all just download the non-umod version... I didnt download the umod, because its even more bugged then Steam... :P

Riccon
3rd Aug 2005, 11:54 AM
Nothing's working. At all. Ever.

I downloaded the mod from one of the sites listed and put it in a folder called AlienSwarm in the UT2k4 folder. What now?

I've tryed double clicking everything I usefuly can. I followed the instructions above only to find that the mod was already recognised. This is realy beginning to bug me now. I've only had UT for three days now, and this is the first mod I've ever downloaded so is there something I'm missing?

Please help 'cos I realy wanna go :wolfe: and maybe a bit of :wildcat: but I can't :crash: to save my life.

Fuzzy Bunny
3rd Aug 2005, 12:14 PM
I think all that was needed to do for 1.2 was unzip the zip file to your UT2004 folder (generally C:\UT2004). Then you start up UT2k4 and click Community on the main menu, find Alien Swarm under the list of User Mods, click it, and then click the Activate Mod button. UT2k4 should then shutdown and restart as Alien Swarm.

Riccon
3rd Aug 2005, 01:33 PM
Ahhhh, right then. I was trying to do it from the windows explorer place. :D

Cheers,

Baz
3rd Aug 2005, 05:47 PM
Welcome to City Aliens Swarm. Its safer here.

DeepQantas
3rd Aug 2005, 07:04 PM
Someone unsticky this topic, seeing how there no longer is an up-to-date UT4MOD version of Alien Swarm?

Fuzzy Bunny
3rd Aug 2005, 09:25 PM
I kinda wish there was, my friends have computers that don't like zip files...

Riccon
4th Aug 2005, 05:53 AM
Um...

Sorry to bother you again but...

Still not working too well. I must be missing something pretty basic, right? I can see where it say's Alien Swarm in the top right hand side of the Communtity Mod page, (although it doesn't appear on the list to the left. Maybe this is the problem...Does it need an install?) and I click Activate. The button highlights and...

Nothing. Zilch. Zippo.

Please help!

Carth
4th Aug 2005, 10:06 AM
You extract the zip to AlienSwarm inside the UT2004 directory, and then double click on UT2004\AlienSwarm\AlienSwarm.exe. That executable will launch UT2004 with the relevant mod options so you don't have to start vanilla UT2004 first and choose it from the community menu. If it doesn't work, the chances are you installed it wrong.

Tsura
18th Oct 2005, 01:19 AM
It's...Uh...Well, I have Alien Swarm on the mod list, along with the description of the mod. I double click it, it goes away, just like Frag Ops. Unfortunately, unlike Frag Ops, it doesn't come back as Alien Swarm. The executable also does nothing.

Moses2k
18th Oct 2005, 01:44 AM
Have you tried reinstalling BeOS? If so, well, there's your problem. Alien Swarm doesn't run on BeOS.

Tsura
18th Oct 2005, 02:19 AM
What's BeOS? I meant the mod list in UT2K4.

Baz
18th Oct 2005, 10:49 AM
Bit odd its in the modlist but the exe does nothing. Do the usual stuff :) make sure your using new drivers, latest patch of swarm and unreal, and delete and reinstall swarm. if all else fails, you need to buy more harddrives

immortius
18th Oct 2005, 10:53 AM
It would be helpful to know if there are any errors listed in the UT2004.log after trying to run the mod.

Nok
21st Oct 2005, 08:09 AM
You extract the zip to AlienSwarm inside the UT2004 directory, and then double click on UT2004\AlienSwarm\AlienSwarm.exe. That executable will launch UT2004 with the relevant mod options so you don't have to start vanilla UT2004 first and choose it from the community menu. If it doesn't work, the chances are you installed it wrong.
Thats what I did, after it finished downloading it saved it to WinRAR, so I extracted it to the UT2K4 folder, clicked on its icon and it gave me this error message:

"UT2004 Build UT2004_Build_[2004-03-03_02.42]

OS: Windows 2000 5.0 (Build: 2195)
CPU: AuthenticAMD PentiumPro-class processor @ 1532 MHz with 511MB RAM
Video: RADEON 9800 PRO (6553)

Failed to enter AlienSwarmStartup.ut2: Can't find file 'AlienSwarmStartup.ut2'

History: UGameEngine::Init <- InitEngine"

immortius
21st Oct 2005, 08:48 AM
Thats what I did, after it finished downloading it saved it to WinRAR, so I extracted it to the UT2K4 folder, clicked on its icon and it gave me this error message...
As is already stated in this thread (and the alienswarm readme, incidently), you need to have a PATCHED version of UT2004. At least version 3270.

Nok
21st Oct 2005, 08:53 AM
As is already stated in this thread (and the alienswarm readme, incidently), you need to have a PATCHED version of UT2004. At least version 3270.
Ok I updated it to 3355, but its still giving me an error, not the same from before:

UT2004 Build UT2004_Build_[2005-02-15_17.02]

OS: Windows 2000 5.0 (Build: 2195)
CPU: AuthenticAMD PentiumPro-class processor @ 1532 MHz with 511MB RAM
Video: RADEON 9800 PRO (6553)

Failed to enter AlienSwarmStartup.ut2: Can't find file for package 'AlienTech'

History: UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Free

Nok
21st Oct 2005, 09:55 AM
I updated from the first version to 3355, should I have gotten 3270 before 3355?

immortius
21st Oct 2005, 10:21 AM
after patching you'll need to remove alienswarm and then re-install it.

I'm also assuming you're installing it to Ut2004/Alienswarm.

Kuzzeddie
26th Jan 2006, 05:23 PM
UT2004 Build UT2004_Patch_[2004-07-27_14.28]

OS: Windows XP 5.1 (Build: 2600)
CPU: AuthenticAMD PentiumPro-class processor @ 1501 MHz with 1023MB RAM
Video: NVIDIA GeForce FX 5200 (8198)

General protection fault!

History: UObject::ProcessEvent <- (AoMarine AlienSwarmStartup.AoMarine1, Function AoPrototype.AoMarine.PostNetBeginPlay) <- BeginPlay <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Browse <- UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Free

general protection fault?? whats this?? :faith:

Bucchus
26th Jan 2006, 06:53 PM
Hmm, did you try to use the server browser while in game?

Phantaloz
27th Jan 2006, 08:27 AM
General Protection Fault is just the normal error that UT2k4 gives when it does something wrong/it doesn't give a shit about what you want/you've done something wrong

(For me they were the two first ones...On the old computer. Haven't got them anymore :) )

DiP
27th Jan 2006, 12:17 PM
Immortuios(or however you spell your name), Just to say. That UT4Mod's dont work because you unistalled Ut2004 Demo and installed the ful game, Because all i did was get a (cracked) version of ut2003, Then when ut2004 came out i firstly uninstalled ut2003, Deleted all the things that came with it. Restarted, And installed ut2004(DVD, This is waht i think causes it) and my UT4Mod's dont work. I just use a UT4MOD extractor. If anybody else's umod's don't work then try those things first. If it still doesn't your like me. Millions of reinstalls(or uninstalling and installing) doesnt work either. Your stuffed basicaly. As i said, I think it has something to do with buying the DVD version of it. Or if you bought a cd version, Then it was basicaly the first shipment of the game. This is what i think, It may not be true, it may be true. How to get UT4MODS working is like asking someone "Whats the speed of an unladen swallow?"

Phantaloz
27th Jan 2006, 12:44 PM
"Whats the speed of an unladen swallow?"

"What is the average airspeed velocity of an unladen swallow"! :nono:

DiP
27th Jan 2006, 04:30 PM
"What is the average airspeed velocity of an unladen swallow"! :nono:
11mph.

Carth
27th Jan 2006, 07:11 PM
How wrong can you be?

DiP
27th Jan 2006, 07:13 PM
There is half a chance im wrong, But then again, Thats another 50% that i'm right. 50%, You can't beat that can ya!?

Carth
27th Jan 2006, 07:39 PM
There is half a chance im wrong, But then again, Thats another 50% that i'm right. 50%, You can't beat that can ya!?
Actually I can. 51% would beat it, but I could just be 100% correct instead :)

BiG_D
27th Jan 2006, 08:25 PM
And, in fact, the probability in this case is not 50/50
To figure it out, we first need to know how many possible answers there are. Let's assume the answer must be a whole number, and it can't be negative. That leaves, let's see... infinity. So, the chance that you're right is 1/infinity

Not odds I would play...

Fuzzy Bunny
28th Jan 2006, 12:20 AM
I'm willing to bet he's correct ;)

The answer was in my sig awhile back.

Moses2k
28th Jan 2006, 12:24 AM
I'll one-up you. I'm willing to bet that no one cares. ;)

Soulcrusher
21st Feb 2006, 02:48 PM
What are we talking about....??:P
UT2004 Build UT2004_Patch_[2004-05-10_17.18]

OS: Windows XP 5.1 (Build: 2600)
CPU: GenuineIntel Unknown processor @ 3004 MHz with 511MB RAM
Video: NVIDIA GeForce 6800 XT (8185)

General protection fault!

History: UObject::ProcessEvent <- (AoMarine AlienSwarmStartup.AoMarine1, Function AoPrototype.AoMarine.PostNetBeginPlay) <- BeginPlay <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Browse <- UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Free

I only have this when i tried alienswarm from the mods page in ut...

BiG_D
21st Feb 2006, 02:51 PM
Install the newest ut patch, delete your swarm folder, and install it again.

runedot
1st Jun 2006, 02:04 AM
Edit: Nevermind. I reinstalled the latest patch, reinstalled Swarm, and it worked. Weird.


I've just downloaded the mod and I get an error...
And it took me ages to download as well!



General protection fault!

History: UObject::ProcessEvent <- (AoMarine AlienSwarmStartup.AoMarine1, Function AoPrototype.AoMarine.PostNetBeginPlay) <- BeginPlay <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Browse <- UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Free

djantonv
4th Apr 2009, 06:28 AM
Im having trouble with alien swarm because i save it to ut2004 and then i dont know what to do:(

Waki
4th Apr 2009, 12:10 PM
update UT2004 to newest patch,download Alien Swarm,extract map into the UT2004 map (if no need to extract from rar then just move the map into ur UT2004 map).

make a new short cut,its in the AlienSwarm map.

Moses2k
4th Apr 2009, 03:56 PM
Maybe he's asking how to open the map in-game?

Tilde (~) console, type "map <mapname>" without quotes, right?

Waki
5th Apr 2009, 07:07 PM
"cant launch it" is the head line so think he means how to start Alien Swarm,but that might be another way of reading it. =)

Moses2k
6th Apr 2009, 02:26 AM
Where I come from (Slashdot), we don't RTFA. :)

Muirios
17th Feb 2010, 06:05 PM
Ok I updated it to 3355, but its still giving me an error, not the same from before:

UT2004 Build UT2004_Build_[2005-02-15_17.02]

OS: Windows 2000 5.0 (Build: 2195)
CPU: AuthenticAMD PentiumPro-class processor @ 1532 MHz with 511MB RAM
Video: RADEON 9800 PRO (6553)

Failed to enter AlienSwarmStartup.ut2: Can't find file for package 'AlienTech'

History: UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Free

hi, ye i got this error too so i deleted alien swarm and then reinstalled and didnt patch it...and it worked, i think there must be something wrong with the patch that clashes or something cos its working fine now i can create servers and join them too cept im on the wrong version to join servers lol...

Fuzzy Bunny
17th Feb 2010, 06:54 PM
If it's the exact same error, it probably means the patch wasn't applied correctly. If you unzip the contents of the patch to an empty directory, you can put everything in the appropriate folders manually.

lightfoot
18th Feb 2010, 07:40 AM
working fine now ... cept im on the wrong version to join servers

As a player, you should go up to 1.34. You will still be able to connect to servers at 1.32.

As server admin, you could just as well stick to 1.32. That way, ppl who didn't do the update yet (either cos they don't have a widescreen, or just don't know of the patch yet) will still be able to play.