Results 1 to 6 of 6

Thread: Linux dedicated.

  1. #1
    New Member Kvbev's Avatar
    Nov 2007

    Question Linux dedicated.

    im setting up a linux server dedicated box that will be used privatly to host alien swarm games.

    im just looking for what needs to be downloaded and what mutators need to be loaded at boot to get the server running.

    the documentation here:
    seem to no longer exist so im just looking for a getting started page and some basic configuration that needs to be done.

    also its running arch linux 64bit on the machine. i have to 32 compatability librarys installed but is there a 64bit as binary i need? or can i just run it from the ucc-bin-linux-amd64 file?

    any server setup docs appreciated.

  2. #2
    Jan 2003
    Those links are broken.

    Go here: (Bit outdated, just download the latest Linux patch)

    You can probably just use ucc-bin-linux-amd64 give them a try.

  3. #3
    Member Felix's Avatar
    Apr 2006
    Frankfurt a.M., Germany
    It's all here

    and you can find the needed files here -> Downloads -> as

  4. #4
    New Member Kvbev's Avatar
    Nov 2007
    ok maybe im doing this wrong so lets start from scratch.

    ive downloaded the dedicated 3339 server tar for linux.

    i downloaded the linux 3369 patch, side note: this looked like the client patch, is there a seperate patch for linux dedicated or is it same file?

    unzipped and applyed the patch.

    unzipped alienswarm v13 and applied the v132 patch.

    i go to run the server and i get bad mod error. this happens with both the ucc-bin and ucc-bin-linux-64bit, same error. how can i resolve this? im currently running listen server to play with my friends but i would prefer the linux dedicated on my other box. any ideas?

    the server is currently setup within its own username and run from there. i use ssh to my box so i cant use any gui installs or such. and dont want to.

    ive setup a ut99 server before, however thats a little easier as the latest version 436 just all comes in one tar for dedicated. is there an all in one tar for 3369?

    also for ut99 theres this nice little script ASU used for dedicated servers to start and stop and what not. is there a ut2004 equivilent of this?

  5. #5
    Member Felix's Avatar
    Apr 2006
    Frankfurt a.M., Germany
    What I did, might not be the most efficient way, but it worked:

    I installed ut2004 from cd on a local Linux pc, tested it, then copied the whole directory to the server. When you run it there you have to use the free server licence.

    If this still does not work, check the logfiles for errors. You might have a problem with an outdated gcc version.

  6. #6
    New Member Kvbev's Avatar
    Nov 2007

    moved to centos

    [ut04srv@pyohost ~]$ ./swarmsrv.init
    Executing Class Engine.ServerCommandlet
    Browse: AO-ReactorCore?Name=Grunt?Class=Engine.Pawn?Character=Jakob?team=255
    Failed to load 'AO-ReactorCore': Can't find file 'AO-ReactorCore'
    Failed to load 'Level None.MyLevel': Can't find file 'AO-ReactorCore'
    Failed to enter AO-ReactorCore: Can't find file 'AO-ReactorCore'
    Executing UObject::StaticShutdownAfterError
    Failed to enter AO-ReactorCore: Can't find file 'AO-ReactorCore'
    Exiting due to error
    FileManager: Reading 0 GByte 34 MByte 18 KByte 771 Bytes from HD took 0.105587 seconds (0.105587 reading, 0.000000 seeking).
    FileManager: 0.000000 seconds spent with misc. duties
    Name subsystem shut down
    [ut04srv@pyohost ~]$
    thread revival.

    moved to centos from arch on linux box. using same install. everything is setup the same, but now i get that.

    cd System;
    ./ucc-bin-linux-amd64 server AO-ReactorCore -mod=AlienSwarm -ini=..\AlienSwarm\System\AlienSwarm.ini -multihome=$(returnipraw eth1) -nohomedir;
    cd ..;
    i saw on the alienswarm linux dedicated doc about an error like that, but i dont think is related, i started with the file for the server which is later patch.

    also tryed with just ucc-bin, same error. and added .ut2 to end of map name, same error. shouldent need the extension as it worked w/o it fine on arch.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Dedicated Server!
    By Fuzzy Bunny in forum Alien Swarm 2K4 Discussion
    Replies: 20
    Last Post: 29th Aug 2005, 04:21 PM
  2. ut dedicated server
    By reemulmyu in forum Alien Swarm 2K4 Tech Help
    Replies: 7
    Last Post: 9th May 2005, 02:13 AM
  3. dedicated server under Linux behind Alcatel ADSL modem
    By longshot in forum Alien Swarm 2K4 Tech Help
    Replies: 1
    Last Post: 27th Mar 2005, 11:32 AM
  4. Problem w/ dedicated Linux server and standalone maps.
    By MarcJ in forum Alien Swarm 2K4 Tech Help
    Replies: 2
    Last Post: 23rd Jul 2004, 08:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts