Black Cat Forums   Alien Swarm - Steampowered Forums
Alien Swarm 2K4 - ThieveryUT
Black Cat Games - TTLG Forums

Go Back   Black Cat Forums > Alien Swarm 2K4 Forums > Alien Swarm 2K4 Tech Help

Notices

Reply
 
Thread Tools
Old 28th Jan 2007, 10:23 AM   #1
Slacca
New Member
 
Registered: Jan 2007
Posts: 18
Linux noob install problems

Hi

I installed UT2004 DVD on Ubuntu Edgy using the 'sh' linux installer. However i did not do this as root so my UT2004 folder is in my home directory. However UT2004 is now fully patched and works fine.


However when it comes to AlienSwarm i downloaded the file, unzipped it and then copied it into my UT220 dir as described above - however i can't get ti to run and get these messages in the terminal:

voteslave@voteslave-desktop:~/ut2004/AlienSwarm$ ./Alien-Swarm-Linux
bash: ./Alien-Swarm-Linux: Permission denied
voteslave@voteslave-desktop:~/ut2004/AlienSwarm$ sudo ./Alien-Swarm-Linux
Password:
sudo: ./Alien-Swarm-Linux: command not found
voteslave@voteslave-desktop:~/ut2004/AlienSwarm$

it doesn't appear as a mod in the Community menu either - i assume this is a permission problem but it won't even run using sudo

what am i doing wrong here?

many thanks
Slacca is offline   Reply With Quote
Old 28th Jan 2007, 11:09 AM   #2
Omega
Member
 
Registered: Jan 2003
Location: .nl
Posts: 2,813
Does your regular user own the file and is the file set to executable?

You can find out by rightclicking on the file and selecting properties or by running the command;
Code:
ls -l Alien-Swarm-Linux
If it's not set to executable, just check the "executable" checkbox in the properties menu or type the following command in the directory where the file is located.
Code:
chmod +x Alien-Swarm-Linux
You can also try running this command to start the mod;
(in ~/ut2004/System)
Code:
./ut2004 -mod="AlienSwarm"
Omega is offline   Reply With Quote
Old 28th Jan 2007, 11:36 AM   #3
Slacca
New Member
 
Registered: Jan 2007
Posts: 18
thanks for the quick reply Omega - i have tried what you suggested but no luck - here's the terminal output:

=====================================

voteslave@voteslave-desktop:~/ut2004/AlienSwarm$ ls -l Alien-Swarm-Linux
-rw-r--r-- 1 voteslave voteslave 46 2004-05-23 14:50 Alien-Swarm-Linux

** i changed the file to be executable here **

voteslave@voteslave-desktop:~/ut2004/AlienSwarm$ ./Alien-Swarm-Linux
./Alien-Swarm-Linux: line 2: exec: ut2004: not found

voteslave@voteslave-desktop:~/ut2004/AlienSwarm$ cd ..

voteslave@voteslave-desktop:~/ut2004$ ./Alien-Swarm-Linux
bash: ./Alien-Swarm-Linux: No such file or directory

voteslave@voteslave-desktop:~/ut2004$ cd system
bash: cd: system: No such file or directory

voteslave@voteslave-desktop:~/ut2004$ cd System

voteslave@voteslave-desktop:~/ut2004/System$ ./ut2004 -mod="AlienSwarm"
bash: ./ut2004: No such file or directory

voteslave@voteslave-desktop:~/ut2004/System$

======================================

going back ot the instructions in the readme it says:
"To play Alien Swarm, run UT2004\AlienSwarm\AlienSwarm.exe
Linux users can run ./Alien-Swarm-Linux in the same directory."

but it doesn't seem to find the UT2004 file??


any other ideas - or have i done something wrong here?

many thanks

Slacca

edit - i haven't rebooted - is that necessary?
Slacca is offline   Reply With Quote
Old 28th Jan 2007, 11:54 AM   #4
Slacca
New Member
 
Registered: Jan 2007
Posts: 18
does the Alien-Swarm-Linux script need changing to let it 'find' UT2004?

is the fact that UT wasn't insatlled in usr/local messing things up?


Slacca
Slacca is offline   Reply With Quote
Old 28th Jan 2007, 01:04 PM   #5
Felix
Member
 
Felix's Avatar
 
Registered: Apr 2006
Location: Frankfurt a.M., Germany
Posts: 986
just to make sure that it has nothing to do with permissions, try to run it as root or do chmod -r 777 on the UT2004 dir.
Felix is offline   Reply With Quote
Old 28th Jan 2007, 01:28 PM   #6
Slacca
New Member
 
Registered: Jan 2007
Posts: 18
how do i chmod a directory and all its sub-directories? (which dir do i need to be in to do it?)

thanks


i tried this:
voteslave@voteslave-desktop:~$ sudo chmod -r 777 ut2004
Password:
chmod: cannot access `777': No such file or directory
Slacca is offline   Reply With Quote
Old 28th Jan 2007, 01:43 PM   #7
Slacca
New Member
 
Registered: Jan 2007
Posts: 18
ok - i tried this which seemed to do something:

teslave@voteslave-desktop:~/ut2004$ chmod -R 777 /home/voteslave/ut2004
voteslave@voteslave-desktop:~/ut2004$

but i still get this:

voteslave@voteslave-desktop:~/ut2004/AlienSwarm$ ./Alien-Swarm-Linux
./Alien-Swarm-Linux: line 2: exec: ut2004: not found
voteslave@voteslave-desktop:~/ut2004/AlienSwarm$ sudo ./Alien-Swarm-Linux
Password:
./Alien-Swarm-Linux: line 2: exec: ut2004: not found
voteslave@voteslave-desktop:~/ut2004/AlienSwarm$


it looks like it just can't find UT2004 - is it some sort of PATH problem?
Slacca is offline   Reply With Quote
Old 29th Jan 2007, 10:05 AM   #8
Butters
Member
 
Butters's Avatar
 
Registered: Jun 2004
Location: >:D-/-<
Posts: 593
Yes.. the executable ut2004 (which is just a shell script calling ut2004-bin iirc) is not in your path (that and it not being executable are the causes of your problem). You can edit the Alien-Swarm-Linux launcher - it's just a shell script - and write in the full path to ut2004 - eg. '~/ut2004/ut2004' instead of 'ut2004'. Else, you can add the ut2004 directory to your PATH environment variable so that it is found by the shell automatically eg.

$ export PATH=$PATH:~/ut2004/

(Normally you want to set the PATH in your startup files.. - see for instance some documentation on bash or whatever shell you use)

You don't need to change all the files' permission to 777 - that's a rather bad practice..
__________________
--
Butters is offline   Reply With Quote
Old 29th Jan 2007, 10:13 AM   #9
Felix
Member
 
Felix's Avatar
 
Registered: Apr 2006
Location: Frankfurt a.M., Germany
Posts: 986
 Originally Posted by Butters: ( link to post ) 
You don't need to change all the files' permission to 777 - that's a rather bad practice..
Sure it is a bad practice. I only suggested that, so that he can be sure that it has nothing to do with permissions, which is very often the case. Once everything is running fine you can go back and set it to 760 or whatever.

By the way Butters: awesome wireframes for the EFR campaign
Felix is offline   Reply With Quote
Old 31st Jan 2007, 09:01 AM   #10
Omega
Member
 
Registered: Jan 2003
Location: .nl
Posts: 2,813
Please let us know if your problem has been resolved, Slacca. That way we can keep it for future reference.
Omega is offline   Reply With Quote
Old 3rd Feb 2007, 06:04 AM   #11
Slacca
New Member
 
Registered: Jan 2007
Posts: 18
sorry for delay in getting back to you - still no luck but i am probably editing the file wrong - what i have done so far (from Butters post) is to edit the Alien-Swarm-Linux file as follows - none of them worked when i tried to then 'run' the same file by double clicking on it

exec '/home/voteslave/ut2004 "$@" -mod=AlienSwarm

exec /home/voteslave/ut2004 "$@" -mod=AlienSwarm

exec ~/ut2004/ut2004 "$@" -mod=AlienSwarm

what am i doing wrong?

am just off to try what omega suggested

Slacca
Slacca is offline   Reply With Quote
Old 3rd Feb 2007, 06:07 AM   #12
Slacca
New Member
 
Registered: Jan 2007
Posts: 18
 Originally Posted by Omega: ( link to post ) 
Does your regular user own the file and is the file set to executable?

You can find out by rightclicking on the file and selecting properties or by running the command;
Code:
ls -l Alien-Swarm-Linux
If it's not set to executable, just check the "executable" checkbox in the properties menu or type the following command in the directory where the file is located.
Code:
chmod +x Alien-Swarm-Linux
You can also try running this command to start the mod;
(in ~/ut2004/System)
Code:
./ut2004 -mod="AlienSwarm"
no luck with this either

voteslave@voteslave-desktop:~/ut2004/AlienSwarm$ ls -l Alien-Swarm-Linux
-rwxrwxrwx 1 voteslave voteslave 55 2007-02-03 11:02 Alien-Swarm-Linux

voteslave@voteslave-desktop:~/ut2004/AlienSwarm$ chmod +x Alien-Swarm-Linux

voteslave@voteslave-desktop:~/ut2004/AlienSwarm$ ./ut2004 -mod="AlienSwarm"
bash: ./ut2004: No such file or directory
voteslave@voteslave-desktop:~/ut2004/AlienSwarm$
Slacca is offline   Reply With Quote
Old 3rd Feb 2007, 06:12 AM   #13
Slacca
New Member
 
Registered: Jan 2007
Posts: 18
maybe the mod part of the script isn't working because i have stuff in different directories?

i tried the path command

export PATH=$PATH:~/ut2004/

with this

#!/bin/bash
exec ~/ut2004/ut2004 "$@" -mod=AlienSwarm

no luck
Slacca is offline   Reply With Quote
Old 3rd Feb 2007, 06:38 AM   #14
Omega
Member
 
Registered: Jan 2003
Location: .nl
Posts: 2,813
How do you start UT2004?

Are there any desktop icons for it?
If so, does clicking on that work?
If it works, you can try copying it and add the prefix -mod="AlienSwarm" to the executable line in the copy's properties.
Omega is offline   Reply With Quote
Old 3rd Feb 2007, 06:54 AM   #15
Slacca
New Member
 
Registered: Jan 2007
Posts: 18
thanks Omega

that worked

would still like to understand why other stuff didn't but at least its working now

cheers

slacca
Slacca is offline   Reply With Quote
Old 3rd Feb 2007, 07:18 AM   #16
Omega
Member
 
Registered: Jan 2003
Location: .nl
Posts: 2,813
Command lines and scripts can be intimidating.

Good to hear that your problem is solved. Have fun playing Alien Swarm.
Omega is offline   Reply With Quote
Old 7th Feb 2007, 07:38 AM   #17
tchatzi
Member
 
tchatzi's Avatar
 
Registered: Mar 2006
Posts: 53
AlienSwarm Linux startup script

Attached is a small script that will launch AlienSwarm for Linux.
Save it as ``AlienSwarm'' under the directory where ut2004-bin is (in my case /home/games/ut2004/System) and make it executable (``chmod u+x AlienSwarm'').
Hopefully, if it doesn't work, it'll tell you what's wrong with it.
Attached Files
File Type: txt AlienSwarm.txt (489 Bytes, 10 views)
tchatzi is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Linux Install Herr 9mm Alien Swarm 2K4 Tech Help 3 5th May 2005 09:14 AM
AS1.2 linux server problems sourcexx Alien Swarm 2K4 Tech Help 15 19th Sep 2004 09:27 PM
I can not install on Linux 3lood_Blade Alien Swarm 2K4 Tech Help 5 19th Sep 2004 04:54 PM
2 problems in linux: joining a server and loading-screen booiiing Alien Swarm 2K4 Tech Help 3 19th Sep 2004 04:47 PM
Linux install script Naib Alien Swarm 2K4 Tech Help 4 19th Sep 2004 06:44 AM


All times are GMT -5. The time now is 03:06 AM.


Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.