Black Cat Forums   Alien Swarm - Steampowered Forums
Alien Swarm 2K4 - ThieveryUT
Black Cat Games - TTLG Forums

Go Back   Black Cat Forums > Alien Swarm 2K4 Forums > Alien Swarm 2K4 Tech Help

Notices

Reply
 
Thread Tools
Old 26th Mar 2007, 05:45 PM   #1
DelXander
Member
 
Registered: Feb 2006
Posts: 171
Crashes while starting Beggarspoint

I was plaing an 8 players CC at UIE, we reached Beggars Point, here is what happened:

+ I select my marine, press ready, map starts, I get a glimpse of the map, -> bang, crash.
+ I start ASW again, load the map, just to see them start the DM and restart map. -> Instead of seeing the roster, it crashes.

Repeat procedure till somebody takes my spot

Here is the error from the logfile:
EDIT:
Actually I could also post it here. *smacks self*
 Quote:
ScriptLog: $$ Felix: no
ScriptLog: $$ [SE]DelX:
ScriptLog: $$ [SE]DelX:
ScriptLog: $$ [SE]DelX:
ScriptLog: $$ [SE]DelX:
ScriptLog: $$ Nurbs: as long as it runs maya and photoshop...
Warning: AoTelicPlayer AO-EFR5-BeggarsPoint.AoTelicPlayer (Function AoPrototype.AoPlayer.PlayerToCursorRotation:006B) Accessed None 'Console'
Warning: AoTelicPlayer AO-EFR5-BeggarsPoint.AoTelicPlayer (Function AoPrototype.AoPlayer.SwitchPrimary:0103) Accessed None 'Weapon'
Critical: Assertion failed: Ptr [File:../../Core/Inc/FMallocAnsi.h] [Line: 32]
Exit: Executing UObject::StaticShutdownAfterError
Exit: Executing USDLClient::ShutdownAfterError
Log: CTRL-C has been pressed.

Log: appRequestExit(0)
Log:
Developer Backtrace:
Log: [ 1] ./ut2004-bin [0x873df19]
Log: [ 2] ./ut2004-bin [0x873e21e]
Log: [ 3] [0xffffe420]
Log: [ 4] /lib/tls/libpthread.so.0 [0xb7fbc199]
Log: [ 5] ./openal.so(Posix_LockMutex+0x20) [0x44452fc8]
Log: Unreal Call Stack: UALAudioSubsystem::Shutdown <- UALAudioSubsystem::ShutdownAfterError <- UObject::StaticShutdownAfterError <- FMallocAnsi::Malloc <- FOpenGLTexture::Cache <- FOpenGLRenderInterface::CacheTexture <- FOpenGLRenderInterface::HandleCombinedMaterial <- FOpenGLRenderInterface::SetSimpleMaterial <- FOpenGLRenderInterface::SetMaterial <- FCanvasUtil::Flush <- UCanvas:rawTile <- UCanvas::execDrawTile <- UObject::execClassContext <- UObject:rocessEvent <- FPlayerSceneNode::Render <- UGameEngine:raw <- USDLViewport::Repaint <- USDLClient::Tick <- ClientTick <- UGameEngine::Tick <- UpdateWorld <- MainLoop
Exit: Exiting.
Log: FileManager: Reading 0 GByte 0 MByte 0 KByte 0 Bytes from HD took 0.000000 seconds (0.000000 reading, 0.000000 seeking).
Log: FileManager: 0.000000 seconds spent with misc. duties
Uninitialized: Name subsystem shut down
Uninitialized: Log file closed, Mon Mar 26 23:11:13 2007

Other maybe unrelated info:
During that campaign I crashed twice randomly on mapchange. No logs collected.

I hope somebody can shed a little light on that issue, I know I got some accessed none issues, but have no idea what that actually means.

Still playing ASw, even if I do lots other things I enjoy a good game every now and then, and I doubt I'd uninstall it anywhere near future even tho it takes lots of space. ^^
DelXander is offline   Reply With Quote
Old 27th Mar 2007, 06:33 AM   #2
Butters
Member
 
Butters's Avatar
 
Registered: Jun 2004
Location: >:D-/-<
Posts: 593
The crash is related to the sound library OpenAl. It seems you are using the one provided with the game - I've heard in the past that it can be flaky. Perhaps you should try using the system one if you have one, or installing a recent version.

You can try if this helps first by renaming the ut2004 copy of the openal library and copying or creating a symlink with the same name to the system/newly installed one. If the crashes stop, overwrite it permanently. If you search for ut2004/openal you should find some more info.
__________________
--
Butters is offline   Reply With Quote
Old 20th Apr 2007, 06:33 AM   #3
DelXander
Member
 
Registered: Feb 2006
Posts: 171
I've been playing a bit of Swarm yesterday and had the same problem. Using one of my systems libopenal resulted in the same problem (crash). Then I used a newer one. Result was no sound at all in swarm, but no crashes. Same with no openal at all.
I'll have a look at different libs, will tell you more later.
DelXander is offline   Reply With Quote
Old 23rd Apr 2007, 04:27 AM   #4
Felix
Member
 
Felix's Avatar
 
Registered: Apr 2006
Location: Frankfurt a.M., Germany
Posts: 986
 Originally Posted by DelXander: ( link to post ) 
I was plaing an 8 players CC at UIE, we reached Beggars Point, here is what happened:

+ I select my marine, press ready, map starts, I get a glimpse of the map, -> bang, crash.
+ I start ASW again, load the map, just to see them start the DM and restart map. -> Instead of seeing the roster, it crashes.

Repeat procedure till somebody takes my spot
Oh, and I was wondering why you left without a word
Felix is offline   Reply With Quote
Old 5th May 2007, 03:24 PM   #5
DelXander
Member
 
Registered: Feb 2006
Posts: 171
Ye, was not on purpose, I never leave without a word. Only if I just lost my hands or connection.

I heard thanos has a solution to the problem, but I couldn't find one.

If the sound works, it WILL crash, and without openal-libs it obviously doesn't crash, but having no sound is no fun. I try to compensate with music, but it ain't the same without the screams and the bug-squishing sounds !

n33d h41p plx plx !!
DelXander is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with starting AS S4RGE Alien Swarm 2K4 Tech Help 16 15th May 2005 09:41 AM
need help starting a server ianflaer Thievery Discussion 1 1st Mar 2005 03:26 PM
Error when starting Rion Alien Swarm 2K4 Tech Help 1 23rd Jun 2004 03:27 AM
Problem when starting up Sabolin Alien Swarm 2K4 Tech Help 4 4th Jun 2004 05:44 AM


All times are GMT -5. The time now is 02:03 PM.


Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.