No announcement yet.

Deciding to install again; need help as usual.

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    The easiest thing to do, would probably to post the code for each campaign's .bat(Sigma/Ortega/Phalanx/Upsilon/Telic/EFR) to load with the only the EFR Mutator in Single Player mode.

    Then sticky that information for all eternity.


    So you would have to close AS each time to load a new campaign, but at least you could play them all with EFR without any hiccups.


    • #17
      Most of what you asked is already answered in the 'Mutators' sticky thread.

      Ah well-
      *produces spoon*

      There is several possibilities of starting a certain mutator config. Either build a txt file called 'whatever.bat' with the following content:
      start ..\System\ut2004.exe AO-Rescue.ut2?Mutator=AoEFRCode.MutEFR -mod=AlienSwarm
      which you can just double-click.
      Once in the game, you vote what you want to play with the F1 menu, the mutator config will stay intact.
      This should work, with the exception of 'plain' sigma and ortega campaigns. If you vote these as campaigns with F1, the telic mutator and stuff will be OFF, for the original experience.
      (You can still have the extra stims there, too, but you will need to click "call vote to custom campaign", and then name each of the maps you want to play in your camp)


      The other way would be to start your swarm game by whatever method, then type into console:
      open AO-Rescue.ut2?Mutator=AoEFRCode.MutEFR
      A command long like that would better be bound to a key of course. "set input U open AO-Rescue.ut2?Mutator=AoEFRCode.MutEFR" at console, to use the U key, for example.


      As you see, it is the 'mutator=...' setting that is of importance, in both methods. It doesnt matter what map is called, and all the other switches do things you dont need to know.


      If you think that all this is complicated, no not really. Unreal is very well-documented, modding it is NOT hard. Source engine is an early derivative, but adds a LOT to the complexity.

      What I mean to say is: All this is complex business, sure, simply because the Engine is complex. You will need to be willing to dig yourself thru some docu, and try some things out. No one can spare you that time, if you want to make use of any not-so-obvious feature.


      • #18
        Ok neither of those code commands are working lightfoot, and I know they should be. (Creating .bat or just runnin EFR mutator from console or callvoting)

        I dunno, maybe there is so missing files in the Telic zip or something, I'm going to have to check.

        Am I required to run the MutAoOption mutators, or at least have them installed; it doesn't make sense why it is not working.


        So okay, the mutator is not sticking for some reason, and not loading in either. I dunno if it could possibly be something to do with the latest widescreen patch.


        Tried just loading the Telic(standalone) mutator as well; same results.


        Update again:

        Originally posted by Fuzzy Bunny View Post
        start ..\System\ut2004.exe AOL-TelicCampaignLobby.ut2?Game=AoCustCamp.AoCCLobbyGameInfo?CustCampStr=AoTelicCamp.AoCCTelicCampaign?CampaignSlot=11?NewGame=Yes?SlotName=Telic?CampaignType=Custom?Mutator=AoEFRCode.MutEFR -mod=AlienSwarm
        So apprently it is now working, after "just trying" again by changing with callvote.

        I have no idea why it is working now, I didn't change any files or copy+paste over. Makes no sense.
        Last edited by Jimyd; 8 Jun 2010, 11:42 AM.


        • #19
          So here if is the order I installed everything:

          UT2004 1.0 CD Diskcs
          Latest UT2K4 Patch
          AlienSwarm 1.3 Patch
          AlienSwarm 1.34 Patch
          Played 1 round of UT2K4 DM(wasn't neccessary though).
          Played 1 default round of AlienSwarm, Single Map then started a Single Campaign map.
          Loaded Game with code below; mutator didn't stay when changing maps:

          Originally posted by Fuzzy Bunny View Post
          start ..\System\ut2004.exe AOL-TelicCampaignLobby.ut2?Game=AoCustCamp.AoCCLobbyGameInfo?CustCampStr=AoTelicCamp.AoCCTelicCampaign?CampaignSlot=11?NewGame=Yes?SlotName=Telic?CampaignType=Custom?Mutator=AoEFRCode.MutEFR -mod=AlienSwarm
          I deleted both AlienSwarm+AlienSwarmUser Configuration Files; ran AlienSwarm Default Executable.

          Tried just manual loading EFR mutator code Lightfoot posted. Didn't work.

          Exited and re-copy+pasted the Telic+EFR .ZIP.

          Started AlienSwarm Default Executable and manuall loaded EFR Code; not working. Exited, restarted AlienSwarm Default Executable and manually loaded just the Telic Mutator; still didn't work.

          Exited game, then loaded Fuzzy Bunny's .bat EFR code; mutator is holding and working properly(loading from .bat;changing maps and whole campaigns and making custom campaigns).

          I'm running Vista with all firewalls off.

          I'm going to system restore to the point after I installed after installing everything without even loading the game up(fresh UT2K4/AS install).

          Going to try and reproduce this.


          My only theory, is that somehow the Telic Only Mutator was already loaded(activated) from the Default install of AS, and that I somehow turned it off.

          Dalai, when you update to the 1.34 patch, all the New Campaign Slots Names(Sigma+Ortega) are filled with like Test1/Dalai/abcd/etc. and with and without Commanders in the Campaign Info. So I don't know if that could cause any problems, but it really doesn't make sense why that should screw anything up.


          So okay I'm going to System Restore now and try and reproduce all this, maybe my Laptop is haunted or something and is messing with me(would at least be an understandable explanation).


          • #20
            LF's .bat and console options should work...
            I think I've had problems when I used the open command from the main menu before though. One time I actually ended up playing UT2k4 DM in a Swarm map somehow. It might've had to do with the gametype not being specified. I know you can specify gametypes in UED, but I don't know how much the game takes that into account. Start up a single map, then try:
            open AO-Rescue.ut2?Mutator=AoEFRCode.MutEFR
            and vote for maps/camps. As LF pointed out, Sigma and Ortega would have to be custom camps to have the Telic/EFR.
            Based on a true story.
            The prequel.


            • #21
              LOL I just got that bug the other day.

              It was first person DM on a Swarm map.

              Was pretty bad.


              • #22
                So update:

                Here is what doesn't work at all:

                start ..\System\ut2004.exe AO-Rescue.ut2?Mutator=AoEFRCode.MutEFR -mod=AlienSwarm

                As a .bat file, EFR does not load whatsoever.

                Sorta works:

                start ..\System\ut2004.exe AOL-TelicCampaignLobby.ut2?Game=AoCustCamp.AoCCLobbyGa meInfo?CustCampStr=AoTelicCamp.AoCCTelicCampaign?C ampaignSlot=11?NewGame=Yes?SlotName=Telic?Campaign Type=Custom?Mutator=AoEFRCode.MutEFR -mod=AlienSwarm

                Telic is loaded with EFR, but when I switch campaigns(Phalanx for example), or vote for a custom string of maps, the EFR mutator does not stay/stick/load.

                Works temporarily only:

                open AO-Rescue.ut2?Mutator=AoEFRCode.MutEFR

                Manually start up game and use console with the line above.

                EFR loads, but still does not stay/stick/load.


                I've tried both SinglePlayer and Hosting a Local Server with the same results.

                Is there something I need to enter into the AlienSwarm.ini Configuration File in order for the game to keep the settings when switching maps or something?

                I don't understand why the game basically forgets that mutator was even entered in after switching to a new map/campaign(custom or pre-defined).

                Yeah I know...


                P.S. I did delete every single pre-saved/pre-started Campaigns from the SinglePlayer menu(there was a bunch of them named Dalai/Test1234/Etc.).

                I have tried deleting both AlienSwarm Configuration Files and ran default AlienSwarm so the game would recreate them, to make sure that wasn't the problem.

                Could I possibly be in a debug mode or something? Doesn't seem like that would make a difference even if I was.


                • #23
                  So I figured out you have to put this in the AlienSwarm.ini Configuration file:




                  That made this .bat file work:

                  start ..\System\ut2004.exe AOL-TelicCampaignLobby.ut2?Game=AoCustCamp.AoCCLobbyGa meInfo?CustCampStr=AoTelicCamp.AoCCTelicCampaign?C ampaignSlot=11?NewGame=Yes?SlotName=Telic?Campaign Type=Custom?Mutator=AoEFRCode.MutEFR -mod=AlienSwarm

                  That will load the EFR mod correctly which allows me to switch maps and make Custom Campaigns with Telic Stims, Helmets, and the rest.


                  However, once I exit the game and try to continue from Last
                  Custom Campagin or Last Voted Campaign, the game only loads the Telic+EFR Weapons but not Telic Stims, Helmets, and the rest. It also resets the campaign to Ao-ReactorCore as well.

                  So my questions are:

                  1. What would the .bat file look like to only launch the Last Custom Campaign(with Telic+EFR Equipment, Telic Stims, Helmets, etc.)?

                  2. What would the .bat file look like to only launch the Last Voted Campaign(with Telic+EFR Equipment, Telic Stims, Helmets, etc.)??

                  3. Do I need to run the .bat in Lan Mode for the Telic Stims(etc.) to stay, and what does that .bat look like?

                  4. How do I stop the game from resetting the Campaigns to AO-Reactor core when loading the EFR Mutator? Thus negating any save progress.

                  5. For my own knowledge, what do these Mutate Commands specifically do:

                  Thanks again for helping.


                  • #24
                    Some random answers/ideas/bump

                    -Packed with the Option Mutator comes a java application that can auto create bat files for single play and hosting a dedicated server, though syntax isn't tough to get used to. '-lanplay' is for lan game specifically.

                    -Creating a server from a bat using ucc server command is way better than doing so from inside the game.

                    -To see the log file, you have to bring down the console and type 'showlog'. You want to check it to see everything is ok, or if some packages are missing and a map/mutator can't load correctly etc. If you or anybody else doesn't come up with a solution, you could try to post the log here when the mutator doesn't load as it should.

                    -You don't have to disable your firewall to create or join a server game, though you have to open some ports if you want others to join your server.

                    -ServerPackages=.. have to be added when you want to start a server with mutators/other stuff from these packages.

                    About telic mutator, you can look inside telic mutator help file (telic_manual.htm) that should be in Alienswarm/Help folder. Watchdog are used for testing and should be left at false. Indeed those that you quoted aren't listed in the help file, but I never changed their default values and the mut always worked.

                    -I don't have an explanation as to why the bats provided by other posters don't work as they should. Maybe you don't have permission to write in ini files, or you have them open when you play and game can't read/write them correctly.

                    4. How do I stop the game from resetting the Campaigns to AO-Reactor core when loading the EFR Mutator?
                    What do you mean? You want to continue the cc from inside the game by clicking the GUI or you want to do it from OS?
                    Antikythera mechanism


                    • #25
                      Basically, the game loads up fine now from a .bat, or from using the console when the game is started.

                      The problem is when I quit the game to the main menu. The game won't auto-load Telic Stims/Helmets/Etc. from the Last Custom Campaign and Last Voted Campaign.

                      However, the weapons load fine into the equip menu.

                      Also, that campaign's save progress is lost; the campaign is being reset to AO-ReactorCore.

                      I don't think I could explain it simpler than that. =|


                      So basically, right now, I have to restart from the beginning of the campaign every single time due to campaign reset and to load all the "Telic Extras" for the campaign.


                      • #26
                        So I decided to install this again with the intention of having a wee blast of it this afternoon and then DLing the new one when it's out.

                        I finally managed to get UT2004 running which was a trial by itself. Now when I run ASw though I get "Invalid CD Key" errors. It's a legal/valid key. It still works with vanilla UT2004 just not the mod. Anyone got any ideas?

                        I have the DVD version of the game. It was giving me CD Key errors until I renamed my UT2004.exe to UT2004x.exe because the DVD version is rubbish apparently.

                        Edit: Nevermind fixed it. Just removed every ini I could find and tried again and it started working.
                        Last edited by Wolfbullet; 19 Jul 2010, 09:14 AM.