No announcement yet.

Question about HUD icon colors

  • Filter
  • Time
  • Show
Clear All
new posts

  • Question about HUD icon colors

    Say, I have a customized weapon, with all the scripts running good. I wanted to make the texture for it that appears on the player's screen, to represent it. The HUD Icon.

    I exported the standard rifle's icon from the Ed. I thought that this would be a method to have the right file format, the size, and colors.

    Using these, I made my custom icon. I imported it into the Ed, and linked the weapon script to use it.

    But alas, it didn't work out. The icon got displayed, but something bad had happened to its colors, causing it to be displayed wrong. Like as if that blueish color had been changed slightly, but to something not displayable correctly anymore.

    After some tests I found that it also happens when you make NO changes to the texture file. I mean, if you export a standard icon, and re-import directly. You get the same effect. Looks like this (only worse):

    The first icon is the standard one for the PRifle, and the 2nd is the exported-reimported one. They should look exactly the same, but they don't!

    This picture -part of a screenshot- doesn't show the effect I am talking about so very good, due to the lossy screenie compression, but if you enlarge this pic, the difference should still be recognisable. It looks a lot worse ingame, I tell you, really ugly.

    What is causing this? Does the Ed export into another format than it wants for import?

    How can it be fixed? Maybe I just need the right blue color to make it work?

  • #2
    Hi there
    a long time since my last visit here...

    Well, remember the chainsaw melee weapon ? I have created a custom icon for it. Never get that problem^^

    I have first exported one of the ASw icons to photoshop (I think it was the assalut rifle one), to see how it is exactly done, then I have created mine and imported to my package, without getting any trouble of this kind.
    How strange...
    More than ever hour after our work is never over.


    • #3
      Alright. It was Photofiltre, the prog I used for picture editing, that caused it, I suppose.

      I use that proggy for some time now. Always, unless I have very complicated editing jobs. It is free, and way smaller than the Gimp, or monolith Photoshop, so it pops up in an eyelash. I like that.

      Well, but it seems to do something with the pictures, or with its color tables at least. Something not visible to the human eye, and the files DO meet their specifications. But still, something bad enough, so that the princess that is the UnrealEd cannot stomach the pictures alright anymore...

      The Gimp doesn't do that.

      At least with .tga files. The Ed eats those just as it should, if they have been saved by the Gimp.

      Maybe other programs work too, like l'architect says about PhotoShop. Haven't tried that awful thing. Nor have I tried the other formats, apart from .tga, that the Ed allows for import. Yet.
      Last edited by lightfoot; 24 Sep 2008, 07:57 AM.