Announcement

Collapse
No announcement yet.

How to make an Alien not bleed?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to make an Alien not bleed?

    Assumed that I have a working monster. It bleeds its own blood patches (of a different color) when hurt.

    This results in the monster bleeding in two colors! Not nice.

    So, the question: is there a way to turn the normal green blood patches OFF, or at least change the color?

  • #2
    I guess you have modified the default GibGroupClass in your monster properties ?
    I have coded a few asw npc in the past and that are not using the default red blood. I dont exactly know the way it works with aliens...
    More than ever hour after our work is never over.

    Comment


    • #3
      The monsters are a port only, over from vanilla UT2K4.

      Means, I only made the scripts be subclasses of the AlienSwarm base classes, which are AoAlienPawn for the pawn, and AoAlienController for the brain.

      By doing so, the monsters inherited the green blood, it seems.

      So you say it could be the GibGroupClass section of code, where that happens? I will take a look.

      Comment


      • #4
        Off-Topic: The title would make a great zen riddle.
        My cats are black! How about yours?

        Comment


        • #5
          On a random note, isn't there a mutator somewhere for purple blood?
          Alien Swarm Map List

          Comment


          • #6
            Maybe five bucks would refresh my memory...

            Comment


            • #7
              Ah yes. How could I forget that.

              Maybe because it is a thing from anno 2004. The 'purple blood' mutator BigD did.

              I tried it. See in the screenie what funny thing happened.

              Not sure why, but my guess is it is because AlienSwarm has changed (been updated) since then.

              Apart from that strange effect, the technique used in that mutator will NOT solve my problem. As already mentioned in the Readme, the mutator didn't get rid of the normal blood patches, it only added the purple ones.

              I dug in the scripts and tried things for days now, but still no luck. The possibility of toggling green/red alien blood really complicates things. It only happens on the client side, and it should seem that there is a way to turn it completely off. But no, no easy way at least.

              Damn, how can a thing seeming so simple turn out to be so complex!
              Attached Files

              Comment


              • #8
                Clients can turn all the blood off aswel, right? (aswel as several other useful signs and such.
                Alien Swarm Map List

                Comment


                • #9
                  Yes it may be possible to turn ALL blood off, by adjusting the gore level.

                  Well, again, this isnt a solution for my problem. As I said, I just want these special aliens to not bleed in the AlienSwarm style, cos they got their own blood.

                  I tried setting the bUsesAoGibs bool to false, in the pawn script, hoping it would make the green/red blood stop, but no.

                  I suspect some functions in the AoGibbingPawn parent class to be the source of that blood, and as l'architecte said, it has something to do with the GibGroupClass part of code, but to be honest, I don't understand enough to do more than poking around in the dark, there.

                  Comment


                  • #10
                    I was thinking you could disect the way the game does it, even if you have to write a mutator to acompany the actor.
                    Alien Swarm Map List

                    Comment

                    Working...
                    X