Announcement

Collapse
No announcement yet.

Big problem with storm doors in editor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • JenoLT
    replied
    StormDoors don't work for me either, while SmallDoors are doing well (with same properties) - just don't use stormdoors and take smalldoors instead. Theres no difference (except initial properties, but you can change them :p)

    Leave a comment:

  • NachoMan
    Member

  • NachoMan
    replied
    Well this problem does only seem to occur when I copy a door from one location to another... however;

    I have completely removed the return group from my door, ie there is no name and neither is set to leader, but I still get the crash in game.

    Hm, a thought springs to mind. If you use a storm door mover, do you HAVE to use a door area object with it or not?

    Either way there is a problem because I've had this crash with storm doors with door areas and without, they've crashed set to triggeropentimed, bumpopentimed, and triggeropentimednocloseifnearby

    Leave a comment:

  • Nachimir
    Member

  • Nachimir
    replied
    This happened to me when I copied and pasted a door but forgot to set the return group properly. If door movers refer to the door area of another pair they cause an infinite loop; setting them up to make sure the tags are unique should sort it out.

    Leave a comment:

  • Darkdibblez
    Member

  • Darkdibblez
    replied
    mate i hate doors aswel i try to not add them as much as possible
    but im gonna read a door tut becaus i'm gonna need them on my next map

    Leave a comment:

  • NachoMan
    Member

  • NachoMan
    started a topic Big problem with storm doors in editor

    Big problem with storm doors in editor

    Ok, I'm trying to make a map for AS, but I keep hitting a block when it comes to doors. Sometimes they work, but other times for no apparant reason the whole game crashes when I try to open the storm door. I can weld it shut, trigger it etc, but at the very point where the game tries to physically move the door I get a crash with the following error:

    UT2004 Build UT2004_Patch_[2004-05-10_17.18]

    OS: Windows XP 5.1 (Build: 2600)
    CPU: AuthenticAMD PentiumPro-class processor @ 2288 MHz with 511MB RAM
    Video: RADEON 9700 PRO (Omega 2.5.30) (6430)

    AoMoverStormDoor AO-LostContact2.AoMoverStormDoor49 (Function AoPrototype.AoMover.GetCurrentSealTime:0000) Infinite script recursion (250 calls) detected

    History: FFrame::Serialize <- AActor:rocessState <- Object AoMoverStormDoor AO-LostContact2.AoMoverStormDoor40, Old State State AoPrototype.AoMover.TriggerOpenTimed, New State State AoPrototype.AoMover.TriggerOpenTimed <- AActor::Tick <- TickAllActors <- ULevel::Tick <- (NetMode=0) <- TickLevel <- UGameEngine::Tick <- Level The Hive <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 676F4C57 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free



    It looks to be a bug in the storm door script, either that or I'm doing something seriously wrong here. Can anyone help me out?

    -edit: I have the latest patch for both UT2k4 and AS.
Working...
X