Announcement

Collapse
No announcement yet.

Getting my server to load the Telic equipment + stims by default

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting my server to load the Telic equipment + stims by default

    It seems that though I can later enable the Muts in the web interface, I can't get the server to automatically load the Telic weapons/equipment and stims.

    Is there something I can add to the .ini or the startup command for it?

    This is what I've got atm:

    Code:
    nohup ./$GAME_BIN server AOL-CampaignLobby.ut2?CampaignSlot=1?NewGame=Yes?SlotName=fragM1?Mutator=AoTelicBeta.MutTelic,AoEFRCode.MutEFR,AoResslot.MutAoResslot,AoMiniMuts.MutAoFFIndicator,SSMuts.MutAdminStuff,MutUnlocks.MutUnlocks -mod=AlienSwarm  > /dev/null 2> /dev/null < /dev/null &
    The "Mutator=AoTelicBeta.MutTelic" section is one I've added just now to try and get it working but it's made no difference either way.

    Any pointers would be great, thanks

    edit: I wonder if I need to loads the custom campaign mutator at the start?

    edit2: Not that. Not really sure what I need to do so I'll wait for someone's help :p
    Last edited by FrenchTart; 15th Aug 2008, 08:04 AM.
    Gaming community site:

    http://linktart.co.uk

  • #2
    For starters, the Telic and EFR mutators conflict with each other. You'll want to get rid of the AoTelicBeta section, and I think you'll need to have ?Mutator= before each of the mutators you want to use. I think the reason it's not working is because the server's actually looking for the mutator AoTelicBeta.MutTelic,AoEFRCode instead of just AoTelicBeta.MutTelic. I'm not entirely sure, though.

    And the custom campaign mutator automatically loads in 1.3
    Based on a true story.
    The prequel.

    Comment


    • #3
      As I stated in my post, the AoTelicBeta.MutTelic line was just a test. I removed it shortly afterwards.

      I'm pretty sure that it's loading the full list of mutators with the string I've passed - it doesn't seem to need ?mutator= in front of everything. The issue I think I've identified is that it isn't correctly applying the setting for the EFR mutator - I've changed them in the .ini but the server defaults to EFR/nothing enabled.
      Gaming community site:

      http://linktart.co.uk

      Comment


      • #4
        Did you add the Telic or EFR packages to the ServerPackages section of the ini ? As pointed above you don't need both EFR and Telic, as the EFR mutator includes Telic (IIRC!). Also, the telic changes won't be enabled on the original campaigns (sigma,ortega).

        Some instructions
        --

        Comment

        Working...
        X