No announcement yet.

Help! Help! UT4MOD isn't working!

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help! Help! UT4MOD isn't working!

    Ok, on some computers UT2k4 doesn't seem to set up Windows to recognise UT4mod files. To fix this:
    1. Open My Computer, and then in the menu select Tools->Folder Options...
    2. Choose the "File Types" tab.
    3. Find the ut4mod filetype. If it doesn't exist, click new and add it.
    4. After selecting the ut4mod filetype, click the "Advanced" button.
    5. Give it a name and set an icon if you like.
    6. Click "new..." to create a new action.
    7. Name the action "Install".
    8. For the "Application used to perform this action" box, enter:
      "C:\MyUT2004InstallPath\System\setup.exe" install "%1"
      (with quotes)
    9. Ok your way back to the File Types menu. Then click "Advanced" again check to make sure the Install option is there (Tests showed windows tended to ignore the first time the option was added). If it is gone, re-add it .

    And there you go (hopefully)!
    Last edited by immortius; 24 Jul 2004, 12:04 AM.
    Immortius' Forge

  • #2
    when i try to create the ut4mod extension it says ( The extension '.ut4mod' is already in use by file type 'UT2004.module'. Choose another extension. )

    And ya im having the problem where nothing happens when i click on the aliensawrn_v1.ut4mod extension.


    • #3
      I did everything above too, and mine says "C:/Alienswarm/Alienswarm_v1 is not a valid windows 32" or something, do i open it with something else?


      • #4
        Other solutions include:
        • Go into your UT2004 folder and choose file -> new -> text file. Open it in Notepad and put in: "Setup.exe install AlienSwarm_v1.ut4mod". Then rename the file to "install.bat" and double click on it.
        • Or, as stated in the readme, use this tool to manually extract the files to your UT2004 folder, e.g. target directory is "C:\UT2004\"


        • #5
          I fixed it

          This is how I did it. Real simple and it worked for me... so maybe this'll work for everyone else.

          Go to your main drive, or any folder at all on your HD. Click Tools on the menu at the top, then go to folder options. In the window that opens up click on the File Types tab.

          Now scroll all the way down to the UT4MOD file type extension. Click on that, then click on the restore button. Fixed my UMOD files completely.

          Tell me if this works for you. If what I have said doesn't work out, then I might have another way to get it fixed for ya.


          • #6
            Okay i know have 3 folders from when i used the Umod thing.
            One folder says UT2004AlienSwarm
            Another on says UT2004systems
            The last one says UT2004Music

            These are in my UT2004 Folder and they appeared when i used the Umod.

            When i run UT2004 and go to the user mods and run alien swarm this message pops up:

            "UT2004 Build UT2004_Patch_[2004-05-10_17.18]

            OS: Windows XP 5.1 (Build: 2600)
            CPU: AuthenticAMD PentiumPro-class processor @ 1533 MHz with 255MB RAM
            Video: NVIDIA GeForce2 MX 100/200 (5672)

            Failed to enter AlienSwarmStartup.ut2: Can't find file 'AlienSwarmStartup.ut2'

            History: UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Realloc <- 00C80008 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free <- FMallocWindows::Free"


            • #7
              I understand that's a problem with ut4mod installs.

              You have to make sure the directory you install it to is:

              instead of:

              Of course, in your case you could just rename UT2004AlienSwarm into AlienSwarm, and then move the stuff from UT2004system and UT2004Music into C:\UT2004\System and C:\UT2004\Music... altho you probably would have to delete those files manually later on if you uninstall.

              [Edit: If you uninstall, not when ]
              Last edited by DeepQantas; 2 Jun 2004, 01:31 PM.
              Ah, to be a hero. Keeping such company...


              • #8
                Hi, I'm a little new to these forums but...I'm having a problem getting my game started too... I think this has been said already...But I just want to make sure...When I start up the game...This is what comes up...

                UT2004 Build UT2004_Build_[2004-03-03_02.42]

                OS: Windows XP 5.1 (Build: 2600)
                CPU: GenuineIntel Unknown processor @ 1616 MHz with 511MB RAM
                Video: NVIDIA GeForce FX 5200 Ultra (5216)

                Failed to enter AlienSwarmStartup.ut2: Can't find file 'AlienSwarmStartup.ut2'

                History: UGameEngine::Init <- InitEngine

                Any ideas? Umm...Thanks

                (Edit) Ok..I got the mod to work now...Buy when I press on Join Multiplayer...My game freezes...Anyone know what I should do?
                Last edited by Azn_Boi; 2 Jun 2004, 06:48 PM. Reason: Add something
                Wolfe: WHY...WON'T...YOU...DIE!!!!
                Parasite: MWHAAHHAAHAHHA!!!!


                • #9
                  Did you patch UT2004 before installing AS? If you haven't, patch UT2004 and then delete AlienSwarm.ini in UT2004/Alienswarm/System/

                  Alien Swarm requires the UT2004 patch for some of the mod support it introduces.
                  Immortius' Forge


                  • #10
                    I did everything stated, but when I click it, it now says it cant find the setup.exe, what should i do?


                    • #11
                      i actually fixed that, but i have a diffrent problem. Im trying to install the game and it asks me where to install it to. So i tell it, the folder is E:\Program Files\UT2k4, which it is. But it tells me that UT2k4 is not installed there, help would be a appriciated.


                      • #12
                        Try installing to
                        E:\Program Files\UT2k4\
                        (with that last backslash).

                        If that doesn't work try moving your UT directory elsewhere temporarily. like maybe to E:\UT2004.
                        Immortius' Forge


                        • #13
                          Sorry guys, but I'm stuck. I seem to have Melkinov's original problem: I followed the initial steps of altering the file type, but it says it cant find the setup.exe, it needs something to run it. Melkinov fixed it, but I can't . . .

                          Just out of curiosity, why is a mod so hard to install? I've patched ut2k4 to the latest, but I don't understand why a really good mod that gets a 2-page review in pcgamer is even this frustratingly difficult to get working.


                          • #14
                            My theory is this problem is caused when someone uninstalls the UT2k4 demo after installing UT2k4, but I'm not sure. It would also be caused if you just copied UT2k4 from another computer or something. At any rate, this is the standard UT2004 mod installer (many of the mods use it). Saying that it is hard to install is silly - it is easy to install for most people, you are just unfortunately suffering a bug with your UT2004 installation. This problem was recognised from before the release of the mod, which one of the reasons why a non-umod version of the mod exists. It is also why this thread was created shortly before the mod was released too.

                            Double check you filetype settings, make sure that the path to setup.exe is correct (that is the setup.exe under your UT2004/system path). Make sure you have a setup.exe in your UT2004/system directory. If their is a space in the path to setup.exe, try putting it in double quotes:
                            "C:\Program Files\UT2004\System\Setup.exe" install "%1"

                            If none of this works I guess one option is to download the umod extractor listed in the readme file and manually install AlienSwarm.
                            Immortius' Forge


                            • #15
                              the extractor collapses on me when i tell it to extract . . . it gets started then stops responding.