Announcement

Collapse
No announcement yet.

Alien Swarm on Macs

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alien Swarm on Macs

    Initially we'd planned to include a Mac launcher and installer with Alien Swarm, but we ran into a couple last minute problems with ucc-bin being flaky. I didn't have the sleep or the time to finish it before release, but I'm still working on it. Until it's working, here's the process to get Alien Swarm working on MacOS X.

    Installing Alien Swarm

    1) Update UT2004 to version 3204 if you haven't already -- this is critical! The patch is available here .

    2) Download and extract the non-umod version of Alien Swarm (mirror, torrent). There should be three folders: "AlienSwarm", "System", and "Music".

    3) Find the Unreal Tournament 2004 application, and right click on it. Select "Show Package Contents". Copy the files from the "System" folder you extracted into the "System" folder here. Also copy the files from the extracted "Music" folder into the "Music" folder in the package. Then drag the "AlienSwarm" folder into the package.

    4) Download and extract the Alien Swarm Mac Launcher (mirror, mirror 2). Copy the launcher to wherever you'd like, and run it to launch Alien Swarm.

    Patching to version 1.1

    Download the Mac/Linux 1.1 patch from the Alien Swarm website and extract it. Copy the files in the "AlienSwarm" folder you extracted into their respective places in the "AlienSwarm" folder inside the UT2004 package.

    If you encounter any problems with this, let me know.
    Last edited by DarkBill; 4 Jun 2004, 09:28 PM. Reason: Updated for version 1.1
    Nearly all men can stand adversity -- if you want to test a man’s character, give him power.

  • #2
    okay i followed the above directions...i run the swarm launcher, but nothing happens...the launcher app doesn't even run...it bounces in the dock, then goes away...i have the 3204 patch installed prior to installing the mod, and i did the non-umod install...i will try doing a clean install, but in the mean time if anyone has any advice it would be appreciated.

    Comment


    • #3
      CactuarX: Last time something like that happened to me, with another application, was because the executable did not have execute permission. Though having extracted the file myself and checking via the command line, all the necessary permissions seem to be there.

      Note the following is going to get techie, so if you are not thus oriented this may get a little 'deep':

      If you want to check for yourself, via the command line, go to the directory where 'Alien Swarm Launcher.app' is installed and type:

      ls -l Alien\ Swarm\ Launcher.app/Contents/MacOS/

      If everything is correct the line should start with '-rwxr-xr-x'. If all that seems to be okay, then we are going to need the console to help us. The console is located in /Applications/Utilities/ . Open it and then hit clear, so that we have an empty console window. Next, double click the launcher. If you are running for the first time, you will be asked to locate your UT 2004 install with Alien swarm. If the program dies after that you should hopefully get some error message in the console. If you copy that text and send it to the forum, it should help the people here (note: you may not always something displaying in the console).

      Small disclaimer, I am not part of the development team and I don't have UT2K4 to try running this (my computer is too slow), so the above explanation is based on general experience.

      Comment


      • #4
        Error

        I installed it first as the non-umod version and then with the umod version. I had the same problem both times (launcher bounces then quits). The launcher permissions seem to be fine (i could chmod them if necessery).

        I got the following error in the console:

        ===== Sun May 30 2004 ===== 02:15:14 Europe/London =====
        Failed to enter AlienSwarmStartup.ut2: Can't find file 'AlienSwarmStartup.ut2'



        History:

        Exiting due to error

        I then wrote an applescript application to launch Alien Swarm, and I got an identical error. This file exists in the AlienSwarm/Maps folder, but isnt recognized. If I put this file in the main Maps folder, it is then recognized and another error is generated for another missing file. It seems the only way to fix this problem is to move all the files from the AlienSwarm folder to their respective folders in the main UT2004 directory. However, I don't see why this should be necessery, especially when Red Orchestra seems to work just fine with it's own folder.

        Comment


        • #5
          Did as instructed....but...

          okay i tried out the terminal commands, and everything came out like you dais it should...so write permission would not appear to be the issue at hand...

          As you requested i ran console while running the launcher app, and this is the error message that it produced...

          sh: cd: /Users/jeff/Games /Unreal Tournament 2004.app//System/: No such file or directory
          sh: ./ut2004-bin: No such file or directory

          so i checked this out and there is indeed a System directory within the UT 2004 package, and there is a ut2004-bin contained there in...other info i can provide is that i am running 10.2.8 on a dual 1GHz tower with 1.5 gigs of RAM...

          on a further note...i attempted changing the name of my games folder considering it had a symbol contained in the name, but that was no dice either...

          if there is anything else i can do to help solve this issue please let me know...
          Last edited by CactuarX; 29 May 2004, 09:07 PM. Reason: correcting the Title

          Comment


          • #6
            Originally posted by Python
            I installed it first as the non-umod version and then with the umod version. I had the same problem both times (launcher bounces then quits). The launcher permissions seem to be fine (i could chmod them if necessery).

            I got the following error in the console:

            ===== Sun May 30 2004 ===== 02:15:14 Europe/London =====
            Failed to enter AlienSwarmStartup.ut2: Can't find file 'AlienSwarmStartup.ut2'
            Patch UT2004 to version 3204. You'll also need to delete your AlienSwarm.ini once you patch.

            Originally posted by CactuarX
            As you requested i ran console while running the launcher app, and this is the error message that it produced...

            sh: cd: /Users/jeff/Games /Unreal Tournament 2004.app//System/: No such file or directory
            sh: ./ut2004-bin: No such file or directory
            The problem is an extra slash in that path for some reason. I'll PM you a link to a launcher that should fix the problem. Also, what version of OSX are you running?
            Last edited by DarkBill; 30 May 2004, 12:25 AM.
            Nearly all men can stand adversity -- if you want to test a man’s character, give him power.

            Comment


            • #7
              Thnx...you guys are gods...

              okay i tried your new launcher DarkBill and it works like a champ...i can't express how impressed i am with you and your groups drive for excellence in your work...i also thank everyone else who helped me as well...and to answer your question i am running OS X 10.2.8

              Thnx again...now to go give your mod a complete work out.

              Comment


              • #8
                Originally posted by CactuarX
                okay i tried your new launcher DarkBill and it works like a champ
                Glad to hear it. ^_^ I'll be updating the launcher soon, and will include that fix.
                Nearly all men can stand adversity -- if you want to test a man’s character, give him power.

                Comment


                • #9
                  Tnx, my one worked as well after patching. However, I could have sworn that I patched to 3204 before, and Red Orchestra, which uses the same system as Alien Swarm, worked fine. Quite wierd...

                  Comment


                  • #10
                    Originally posted by Python
                    However, I could have sworn that I patched to 3204 before
                    There was a mac patch before 3204, you may be thinking of that.
                    Nearly all men can stand adversity -- if you want to test a man’s character, give him power.

                    Comment


                    • #11
                      cactuarx send me a link that fixed fixed your alien swarm launcher ive tryed almost everything short of reinstalling my ut2004 hlp........

                      Comment


                      • #12
                        Originally posted by ravenseed
                        cactuarx send me a link that fixed fixed your alien swarm launcher ive tryed almost everything short of reinstalling my ut2004 hlp........
                        The updated Mac launcher is here. The download links have also been changed to the new version. It has a couple minor fixes, but there's no reason to update unless you were having problems with the old one.
                        Nearly all men can stand adversity -- if you want to test a man’s character, give him power.

                        Comment


                        • #13
                          Updated first post with instructions on patching to version 1.1.
                          Nearly all men can stand adversity -- if you want to test a man’s character, give him power.

                          Comment


                          • #14
                            Mac Alien Swarm not workin

                            I tried everything...
                            Heres what Terminal said:


                            Last login: Mon Jun 14 13:12:57 on ttyp1
                            Welcome to Darwin!
                            Scott-Harrells-Computer:~ scottharrell$ /Users/scottharrell/Desktop/Alien\ Swarm\ Launcher.3.app/Contents/MacOS/Alien\ Swarm\ Launcher; exit
                            Can't find 'ini:Engine.Engine.GameEngine' in configuration file

                            History:

                            Exiting due to error
                            logout
                            [Process completed]

                            Comment


                            • #15
                              Stuffit hates .rar files?

                              Mods gimme a sec to explain, this is relevant to the thread, i swear!

                              Trying to expand the V1.1 mac patch, and the Non-Umod, both .rar's, stuffit opens briefly, then pops up this warning:

                              "An error has occurred while expanding the file "Alien Swarm_v1_non_umod.rar" (Format error).

                              Error #17540"

                              Is this my computer (OS 10.3.3, 1Ghz laptop, 15") being problematic or is this a known problem?

                              Comment

                              Working...
                              X