Announcement

Collapse
No announcement yet.

Linux problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux problem

    Hey, I got alien swarm working fine, and played for like 10 hours last night (great mod btw), but now, when I start it up, an assertion fails. I'm pretty sure I didn't change anything related to ut or as, so I'm not sure what's causing this.

    When I click on multiplayer, then click on internet, the program dies. It says, in the terminal, "Crash data output to log file" or something similar. This happens *almost* every time, I've gotten it to try to join a few servers oncce, maybe twice, out of like 20 tries.

    Anyway, here's the relevant portion of the log:

    Code:
    Log: Unreal Call Stack: FTcpLink::ReceivePendingData <- FTcpLink::Poll <- AMasterServerClient::Poll <- AMasterServerLink::execPoll <- UObject::ProcessEvent <- AActor::Tick <- TickAllActors <- ULevel::Tick <- TickLevel <- UGameEngine::Tick <- UpdateWorld <- MainLoop
    Exit: Exiting.
    Log: FileManager: Reading 0 GByte 87 MByte 1009 KByte 961 Bytes from HD took 2.063032 seconds (0.825483 reading, 1.237549 seeking).
    Log: FileManager: 0.000000 seconds spent with misc. duties
    Uninitialized: Name subsystem shut down
    Uninitialized: Allocation checking disabled
    Uninitialized: Assertion failed: rc == 0 [File:UnUnix.cpp] [Line: 2222]
    Uninitialized: Executing UObject::StaticShutdownAfterError
    Uninitialized: Executing USDLClient::ShutdownAfterError
    Uninitialized: Waiting for file streaming thread to finish...
    Uninitialized: OpenAL Audio subsystem shut down.
    Uninitialized: Log file closed, Sat May 29 19:26:31 2004
    I also have the Red Orchestra mod installed, but it worked fine with it installed last night, so I wouldn't think that'd be causing problems.


    Thanks for the help!

  • #2
    I've got this same thing going on. I have RO too, but since it uses it's own directory and ini files like AS that shouldn't be a prob. Got rid of Jailbreak as best as I could which does spread it's files around as if it were UT2k4 itself. Also I'm behind a router btw.

    Heres one more thread along these lines I started :
    click me

    Comment


    • #3
      Please paste links to full longs next time. There are two types of crashes I know about in Linux.

      One is where you click on the internet tab and it crashes. This might possibly have something to do with the servers having lines of JailBreak ini code in the AlienSwarm.ini files.

      The other is where you try to start AS and it crashes immediately. This might have to do something with SDL, but we are still trying to figure out what is going on with this. Because I never had that when we were testing.

      Comment


      • #4
        This bug seems to be caused by using the 'Show All Missions' option in the server browser, use one of the others instead and things should be fine. We'll look into this problem for the first patch.

        Comment


        • #5
          Yea, you're right, it does only seem to happen with show all missions. I figured that out about an hour after posting. =P

          It's weird, beccause I don't recall it doing this the night before last, but maybe I just never clicked on show all missions.

          Thanks for the help.

          Comment

          Working...
          X