No announcement yet.

trouble with multiple servers on one computer

  • Filter
  • Time
  • Show
Clear All
new posts

  • trouble with multiple servers on one computer

    I can't seem to get two AS servers (dedicated) running together on the same computer. With 1.0, I just had two copies of my UT2004 directory, and that worked fine. After upgrading, the second copy stopped working (it would just crash on startup). I didn't want to fight it and figured the new "-ini=...." parameter would help.

    It didn't No matter what I put on the command line, it seems to take the default AlienSwarm.ini file. Here's an example of the cmd line I'm trying to use for my second server (port 7888) and the beginning of the server2.log:

    ucc.exe server AOL-CampaignLobby.ut2?CampaignSlot=2?NewGame=Yes?SlotName=$ -mod=AlienSwarm [B]-ini=..\AlienSwarm\System\AlienSwarm2.ini -userini=..\AlienSwarm\System\AlienSwarmUser2.ini [/B]-log=server2.log -multihome= -port 7888
    gives me a log file starting with:
    Log: Log file open, 06/04/04 21:38:54
    Init: Name subsystem initialized
    Init: Detected: Microsoft Windows 2000 5.0 (Build: 2195)
    Init: Version: 3204 (127.29)
    Init: Compiled: May 10 2004 17:19:20
    Init: [B]Command line:[/B] AOL-CampaignLobby.ut2?CampaignSlot=2?NewGame=Yes?SlotName=$ -mod=AlienSwarm -ini=..\AlienSwarm\System\AlienSwarm2.ini -userini=..\AlienSwarm\System\AlienSwarmUser2.ini -log=server2.log -multihome= -port 7888
    Init: Character set: Unicode
    Init: Base directory: D:\ut2004-3186-dedicatedserver\System\
    Init: [B]Ini:..\AlienSwarm\System\AlienSwarm.ini[/B]   
    Init: Build label:  Build UT2004_Patch_[2004-05-10_17.18]
    Notice how it sees AlienSwarm2.ini in the Command Line part, but then it uses AlienSwarm.ini anyway.

    Has anyone got a workaround for this? It also ignores the -port command line parameter, although I'm not even sure that's a valid UT2004 option.



  • #2
    I think u miss read the readme ditch -mod and it will all work fine.
    Multiplay Clanservers
    [email protected]


    • #3
      Yeah, looks like that did it. Thanks!