Announcement

Collapse
No announcement yet.

Linux installation help.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux installation help.

    I have spent the past 2 hours or so trying to figure out some way to get this mod installed under Linux.

    Using the Loki Installer I get some error about it not being able to create the directory.

    Using the umod install it claims to install fine, but trying to run the script, nothing happens, Unreal never loads. Nothing. The mod never shows up under the Community section either.

    Using the manual, non-umod installation, the mod appears in the Community --> Mods listing, but upon activating it, Unreal closes and something called ucc-bin starts up what appears to be a dedicated server.

    Can someone tell me how to get this working? I assume someone got the Linux version running.

    I have the latest patch, so don't anyone dare tell me to install that.

  • #2
    I'm having problem getting Linux version to run also. I've tried:

    1. creating a soft link in ut2004/System folder for Alien-Swarm-Linux, and running it from there.
    2. running sh ./Alien-Swarm-Linux from the original installed AlienSwarm folder.

    Both are giving me this same error: Failed to enter AlienSwarmStartup.ut2: Can't find file 'AlienSwarmStartup.ut2'

    I don't see the mod in User Mods tab, similar to yutt.

    Please help, because I don't want to play this great mod with WinBlows.

    Comment


    • #3
      Well, I cant help with your exact problem, but I can say AS works fine for me under linux (gentoo, 2.6.7 kernel).

      I set $PATH to include the ut2004 root directory and then 'sh Alien-Swarm-Linux'. To install the patch I used the tarball and copied directory contents to like directories.

      Comment


      • #4
        I have managed to get it working. Managed to get it working on lots of machines actually. All running Fedora Core 1. Here's the basic process I used.

        All of the following need to be done as super-user, either by logging in as root, using sudo, or logging in as a normal user, and using su.

        1. Install ut2k4 (it should default to installing in /usr/local/games/ut2004 and I will assume that this is where you put it).
        2. Patch ut2k4 to 3204 patch or newer. (Alien Swarm MUST have 3204 patch)
        3. Install Alien Swarm 1.0 from umod following the instructions in the readme.txt. Take care here... I recall there being some problems, but I can't remember what they were. If there are problems and the rest of this installation fails, post up the error messages and I might be able to help.
        4. Once the installation completes, make sure you go into /usr/local/games/ut2004/AlienSwarm, and rename the "system" directory to "System".
        5. Test run it. If it doesn't run, something's gone wrong. If it succeeds, proceed...
        6. Patch to Alien Swarm 1.1. I used the rar file for this (I don't really trust umods ). Make sure you extract with FULL PATH, i believe the option is "x".
        7. The installation tells you to delete some file or another... I actually didn't and it still worked without a hitch. *shrug*

        All of that worked for me. I've even got an installation where the data is shared between windows and linux courtesy of gratuitous symlinks and a fat32 partition... ugh... ugly.

        Comment


        • #5
          I solved my problem. I simply deleted the AlienSwarm.ini file in ~/.AlienSwarm, and re-ran Alienswarm. Problem solved

          Comment

          Working...
          X