Announcement

Collapse
No announcement yet.

Mouse Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mouse Problems

    I've been having mouse problems when trying to play Alien Swarm Multiplayer.

    I'm using an intellimouse explorer through a USB connection.

    Basically I can setup a server and get someone to join it. I then get through the level selection screen and hit launch. When it loads the equipment and squad selection screen I've lost all mouse control and I can't move the cursor anymore. Any help would be great.

    -- Hellfury

  • #2
    Does this happen in normal UT2K4?

    Comment


    • #3
      maiby u have (in some way) changed your settings.(or AS did it)
      try to look in your settings for your controls and fix it ?
      the WU empire wil crush SHU and WEI
      and then the world wil END, and it will all be under my command,.... whuahahahahaha

      Comment


      • #4
        I have read some people have had problems with their mouse while playing UT, it stall's and you can't move, only while playing UT2004.

        There are various things to do, to get it working smoother again. Or is it playing other games as well?

        Comment


        • #5
          Under Linux I have a problem too:
          The menu in UT2004 works fine, but the control within the game is not working

          RedOrchestra works fine, AlienSwarm does not. The moment the Alien-Menu shows up (different mouse-pointer), the mousepointer freezes in the middle of the screen. Pressing ESC brings back the regular UT2004-menu where mouse is working again, but all that can be done there is leaving the game or changing options....

          Any ideas?
          I have absolutely no idea what causes this strange behaviour....

          TIA - W75

          PS: PS/2 mouse

          Comment


          • #6
            i have a similar problem i thnk. im using a microsoft intellimouse (the optical blue one). I can select options from the menu and go onto online servers and also start a single player game. the problem i have is the mouse wont work when i try to select a player from the roster or equipment and stuff like that. i have no idea whats causing this as it worked previously. the only thing i did was exit the game and go and install a mic so that i could use voice comms with the guys i was playing with. anyone got any ideas?

            thanks for listening.





            edit: normal Ut2k4 works fine as do all other programs, i have also reinstalled the game once too.

            Comment


            • #7
              RedOrchestra works, Frag Ops too, but AlienSwarm... no way

              In the normal menu I can select everything. I click thrue the menus: "Single-Player", "Campaign", "Move To" and when I hit "Launch", AS is loading the map and in the next screen (Briefing, Roster, etc) the mouse is stuck in center (and has different shape than before), music is playing on.

              Only way out: CTRL-ALT-F1 to console, "killall ut2004-bin" ... or killing X-Server (but that is lame ).

              RedHat 9, Logitech PS2, Kernel 2.4.20-30, latest NVidia (6106 since today, 5336 before), Ti4800SE, .....

              Comment


              • #8
                Okay, you have to assign Menu-key and/or console-key to have a chance to get back to desktop (had deleted all ini-files in home-directory to find out wether this was the problem).
                Once I press ESC the regular menu pops up, leaving me the choices: "Quit Game", "Settings", "Server Browser" ... etc. Mouse-pointer looks then "normal" again (not that big spearhead).

                Comment


                • #9
                  Problem still exists.......
                  Quiting is not an valid option

                  Any other reports from Linux-users?
                  Or is it just the two of us here??

                  *bump*

                  Comment


                  • #10
                    GOT IT!!!

                    Since I observed the problem on any new installed MOD, the problem seemed to be not just AS's.
                    A quick look into the User.ini revealed, that the mouse-axis were not assigned.
                    I do not know how or when this happened, but it must have been after RO/FO installation.
                    Since FO and RO were installed earlier, the AS-installation (1st run?) somehow copied the corrupt lines from the System/User.ini to the AlienSwarm.ini.

                    Please check your AlienSwarm.ini (found in "~/.ut2004/AlienSwarm/system/").

                    This following lines must be in there and not empty behind the "=":
                    MouseY=Count bYAxis | Axis aMouseY Speed=2.0
                    MouseX=Count bXAxis | Axis aMouseX Speed=2.0

                    Good luck - W75

                    Comment


                    • #11
                      I tried adding the lines to my AlienSwarm.ini file, but it didn't seem to help. What section should the entries be in?

                      Comment


                      • #12
                        <-- had that problem its quite simple to fix really if its what i think it is ( im running xp) if your useing a custome windows pointer it will cause it to lock up and act stupid, if u have a custom / downloaded pointer / animated icons or whatever for ur mouse restore the mto windows default then try.
                        My doctor says that I have a malformed public duty gland and a natural deficiency in moral fiber and that I am therefore excuse from saving the Universe

                        Comment


                        • #13
                          Checked my mouse pointer and it is set to the Windows default...so, that still isn't it. Thanks tought

                          Comment


                          • #14
                            Originally posted by thodgson
                            I tried adding the lines to my AlienSwarm.ini file, but it didn't seem to help. What section should the entries be in?
                            Those lines should be in AlienSwarmUser.ini or whatever it is called. AlienSwarm's version of User.ini.
                            Immortius' Forge

                            Comment


                            • #15
                              Thanks. I know they should be in the AlienSwarmUser.ini file, but which section? There are sections with brackets [] surrounding them, which the two line entries need to go under.

                              Comment

                              Working...
                              X