Announcement

Collapse
No announcement yet.

Alien Swarm Bugs Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alien Swarm Bugs Thread

    I'm fairly sure you guys are aware of the bugs existant in the current version (v1.1). But rather than having several topics on one bug posted on here, I think it would be a good idea to create a central bug thread that will coincide with each concurrent release.

    The reason I bring this up is because I've just accidentally "save & proceed"-ed a campaign under the assumption that only one guy with base stats was kia when in fact there were 2 other high stat marines dead. The debrief roster screen led me to this screw up, since (KIA) doesn't always show up next to their name in the tally screen.
    "Who's the moron who put a moron like me in charge?"

  • #2
    I’m not sure if these qualify as mod related issues, but I haven’t seen them mentioned so I thought I’d post them just in case. The fact that they happened so seldom makes them not much of a problem either. They gave me some laughs though.

    Twilight Zone (The Others bug):
    I’ve seen this one only twice, both times on salvage. Anyhow, one of the people playing suddenly turns in to a “ghostâ€‌. When this happened to me, I couldn’t see anyone in my team. And from what I could tell they never saw me either. What I did see was aliens getting shot around me, and I heard my mates without seeing them. Weird thing is the aliens didn’t bother me either. I didn’t get any of the normal symptoms of heavy lag or spikes, and this problem lasted for almost the whole level. The other time I saw this happen I believe Carth was the one who disappeared, I’m not sure his experience was identical but definitely similar. After a restart everything went back to normal. To bad I forgot to try screenshot or demorec this thing, if I see it again I’ll post a link. Maybe this is UT related or an unknown oddity?

    Auto fire multitasking:
    Also happened twice; the game sends me back to desktop spontaneously. When I go back to the game that’s still running my character starts emptying the weapon automatically, until it starts clicking in endless loop. I had pistols both times; don’t know if it happens to other weapons. Maybe I’ve got myself to blame, forgetting to close some program in the background or accidentally hitting some windows hotkey.

    I can’t think of anything else right now that hasn’t been mentioned already.
    EDIT: I forgot, I'm running WinXP
    Last edited by [nt]Leo; 28 Jun 2004, 06:14 AM.

    Comment


    • #3
      Originally posted by [nt]Leo
      To bad I forgot to try screenshot or demorec this thing
      Carth to the rescue

      It only occured to me to take some screenshots at the end actually, but I wish I had a demo of it. Here's a couple of the screenshots (clicky to enlarge):

      Screenshot

      Screenshot

      In the first one I had picked up the flares and thrown them all around the place, and also deployed my sentry. The weird thing was that I could still see the pack of flares I had picked up and I couldn't see the sentry whereas other people could.

      In the second one I was trying to screenshot an alien dying because people were killing them around me (I could hear it, but not see it, except for the remains of the alien).

      When this "ghost" thing happened I could see nobody during whole level, and apparently I triggered no spawns (I ran to the end of the map). According to someone I was still at the start of the level, although as the screenshots show, I wasn't.

      My ping wasn't too bad, but at the time it was jumping very fast (like 5 times a second) so I suppose that had something to do with it. As soon as the game restarted I was fine again.

      Comment


      • #4
        Something kinda like that ghost thing, but it was in CleanSweep, and nobody could see eachother, or the aliens. And using the flamer with a flame sprial didn't hurt friends, but did get me lots'a'kills.
        You spoony bard!

        Comment


        • #5
          My game keeps crashing when I refresh the server browser while connected to a game. I think it’s fair to say it happens about 50% of the time. I’ve got the latest UT patch and I’ve tried deleting AlienSwarm.ini since I installed the patch after AS. Anyone know a different fix for this should I reinstall AS or maybe even UT?


          Crash report:
          UT2004 Build UT2004_Patch_[2004-06-11_16.51]

          OS: Windows XP 5.1 (Build: 2600)
          CPU: AuthenticAMD PentiumPro-class processor @ 2082 MHz with 511MB RAM
          Video: RADEON 9200 (6451)

          General protection fault!

          History: FTcpLink::ReceivePendingData <- FTcpLink:oll <- AMasterServerClient:oll <- AMasterServerLink::execPoll <- UObject:rocessEvent <- (MasterServerClient Ao-Rescue.MasterServerClient, Function IpDrv.MasterServerLink.Tick) <- AActor::Tick <- TickAllActors <- ULevel::Tick <- (NetMode=3) <- TickLevel <- UGameEngine::Tick <- Level Rescue <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 676F4C57 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free

          Comment


          • #6
            I get the exact same thing. Press escape and go to the server browser (just to check for any other games) and you get a GPF.

            Comment


            • #7
              Can the twilight issue be consistently reproduced?
              Nearly all men can stand adversity -- if you want to test a man’s character, give him power.

              Comment


              • #8
                i also experienced some minor problem on the 1st map in single player mode. when you've hacked the door (quite in the beginning) and enter the vent system, you - naturally - ask your team to follow. but if you move 2 quick and go round the corner, two of the marines might get stuck @ the entrance 2 the vent sys. so i thought, they might stay and quard the entrance, 4 that i can pick them up later. but i just continued a lil bit further into the tunnels, until my two team members formerly stuck walked ON the black walls. they moved slowly and couldn't jump down, so i had to restart.

                might have been v1 (not 1.1), so the prob might have already been resolved, i'm just downloading the patch...

                Comment


                • #9
                  Originally posted by WildBill
                  Can the twilight issue be consistently reproduced?
                  Would be fun, but I'm guessing that it's not.
                  Or did you mean �that definitely doesn’t belong here silly' ?

                  Um... Shout outs to my man Norris

                  Comment


                  • #10
                    &quot;ghosting&quot;

                    Right, I was playing online with approximately 8 people, and we were doing great until we reached the area with the lift that moves vertically.

                    My character can squished between the crates and the lift, but, amazingly, this wasn't the interesting bit!

                    I was suddenly able to move 3x the normal speed of my character, I couldn't fire, and I couldn't trigger doors, but I could hit buttons. Aliens payed absolutely no attention to me whatsoever as I sprinted throughout the level, and eventually called down the dropship, while everyone else was still advancing towards the second door.

                    When I said, "Hey! I managed to open all the doors and call down the dropship!", I was greeted by a hail of laughter, as someone said "No, dude, you're still stuck in the elevator!"

                    Approximately 3 seconds later, the dropship came flying overhead.

                    "Mmkay..."

                    Sadly, I couldn't finish the mission because I was stuck inside the elevator, and couldn't jam to the pad.

                    To recreate said bug: Run up to the lift in AO-Uplink, and stand on the top edge, to the right side. Have someone nail the button so you get smashed into the crate.

                    It may take several tries to do this, but I managed to do it 3 times in a row afterwards.

                    Note: If you character becomes unstuck while "ghosting", you'll warp straight back to the lift area.

                    I believe this is what happened to you carth, just sans the 3x speed part.

                    Edit:
                    I've heard of similar "ghost" stories in AO-DanselResearchFacility, and I believe the creator of the map accidentally (or purposefully) embedded the character start points inside the map. You think you're moving, but the server believes you're standing inside a rock.
                    "Humility makes me look better than I really am"

                    Comment


                    • #11
                      Kinda like a bug that was (sill is??) in Thievery. If you stood up while crouching through a vent, the server would think your character was stuck, but you could continue moving around, until you crouched again. At that point you would be zipped back to the vent you were crouching through. Possibly an Unreal Engine problem? Or a Dalai problem?
                      Last edited by BiG_D; 12 Jul 2004, 06:17 PM. Reason: So it turns out theres a 'g' in the word 'bug'
                      It's not my fault everything you like is terrible.

                      Comment

                      Working...
                      X