Announcement

Collapse
No announcement yet.

Overwrite Textures in the game

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Overwrite Textures in the game

    hey everyone

    I got the following problem:

    After editing the Marine skin's, i want to view them ingame.
    But i cant figure out a way to get the game use my textures instead of the ones in the vpk files.
    Even if i create a mod and put them in there in the materialsrc they are not used.

    can someone help me with that?

    thanks, pnx!

  • #2
    To override files in the base VPKs, you have to put them into a VPK of your own.

    Comment


    • #3
      hm, okay.

      Where does the vpk has to be placed? is the addons/mymod/ folder the right one?
      and then in the vpk the folder structure like "materials/models/etc"?
      thanks!

      edit:

      I just tried putting the new vpk into the addons folder: doenst work (even with checked mod in the addons dialog ingame)
      tried to put the vpk into the swarm folder, also does not work
      Last edited by pnx; 28th Jul 2010, 03:45 PM.

      Comment


      • #4
        There was an update on this issue so you might want to try again.
        "- Addon VPKs get priority over base VPKs"

        The vpk file needs to be placed like this:
        \swarm\addons\teslapower.vpk



        When creating your addon the developer wiki says to make the folder structure like:
        \swarm\addons\TeslaPower\
        \swarm\addons\TeslaPower\addoninfo.txt
        \swarm\addons\TeslaPower\models\
        \swarm\addons\TeslaPower\materials\
        etc.

        However, since you're gonna pack it into a VPK file anyway it doesn't really matter where that TeslaPower folder is located. I like to have my stuff at:
        \swarm\TeslaPower\

        The game itself won't find the files there (and thus I won't have two addons listed in-game) and when I drag'n'drop that folder into vpk.exe I'll just move the resulting teslapower.vpk into the \swarm\addons\ folder manually.

        [/rant]
        Ah, to be a hero. Keeping such company...

        Comment


        • #5
          Dalai also added the command line option -override_vpk, which, if I'm not mistaken will allow it to work without using a VPK (if you want to test things first before packaging it, this is very useful).

          Comment


          • #6
            Yeah i just tried out to use my mod again and it worked
            The -override_vpk will be pretty damn useful
            thank you !

            Comment

            Working...
            X