Announcement

Collapse
No announcement yet.

Problem with P4 HT and some games/apps

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with P4 HT and some games/apps

    I recently got a P4 w/HT and I read there were some problems with XP sp1 and HT processors. I do notice some slight pausing on certain games as well. Tony hawk pro skater will run a good 5 min and then have a 2 sec hang then go back to normal. Never had that prob before. UT also has this slight stutter efffect, a lot more often. I have 1G of RAM, but I am mixing HyperX DDR500 with regular PNY DDR333 and forcing the DRAM freq to DDR333 so they balance together, I wonder if that might be the problem. Just curious to know if anyone else with a P4+HT has had any problems or fixes. I guess XP sp2 is suppose to fix some stuff, but in the mean time is there any other patches or fixes known?

  • #2
    Yes, I had problems with other games due to hyperthreading, but it was a crash and not a stuttering problem.

    The answer for many problems is here. Simply disabling hyperthreading.

    Problems with the Thief series, System Shock 2, and Grim Fandango have been fixed by following along with my tutorial.
    Hippopotomonstrosesquippedaliophobia, n. See also Irony.

    Comment


    • #3
      Well I had tried that too, but that didn't seem to fix the problem I was having. It seems my HyperX was CL-3 and my PNY RAM was CL-2, basically means that every 3 cpu ticks there will be a RAM access, on the hyperX. So even though I set the same frequency, the Clock ticks were not in sync, so I took out the PNY RAM and it worked fine with just the 512MB, so I guess I will have to invest in another Hyper X chip. :/

      Comment


      • #4
        While there are some apps that truly do benefit from HyperThreading (10%-30% in some cases), 99% of all games are single-threaded and do not see any improvement with HT on. Of the few multi-threaded games available, even they only see minimal increases in performance.

        If you do not use any of the apps (multimedia encoding/decoding, archiving, etc) that do benefit from HT, or you only use those apps minimally, I say disable it and save yourself some headaches.
        No Linux, No Choice.
        Know Linux, Know Choice.

        Comment


        • #5
          This is what I find most beneficial about Hyperthreading:

          You can have 100% load on the first logical processor and have no problems running any program because it'll use the other logical processor. You don't choke your processor like you would with a single threaded cpu. I can encode a DivX movie(Night of the Living Dead which was recently released for free) and play a new game(Splinter Cell 2) at the same time and not notice the encoding is even happening.
          Hippopotomonstrosesquippedaliophobia, n. See also Irony.

          Comment


          • #6
            Originally posted by Hannu
            Well I had tried that too, but that didn't seem to fix the problem I was having. It seems my HyperX was CL-3 and my PNY RAM was CL-2, basically means that every 3 cpu ticks there will be a RAM access, on the hyperX. So even though I set the same frequency, the Clock ticks were not in sync, so I took out the PNY RAM and it worked fine with just the 512MB, so I guess I will have to invest in another Hyper X chip. :/
            I don't see how the CL rating should cause stuttering. If you have RAM with different timings then the mobo will not allow you to run them at the different timings. The mobo will default to the timings of the slowest stick of RAM.

            In your scenario the HyperX is guaranteed to run CL-3 at it's labeled speed (500) but should have no problem running CL-2 at the much slower speed (333). Even if it couldn't run CL-2 @ 333, then both sticks would be set to CL-3.

            Basically, it is impossible to run them at different timings so IMO this can't be the cause of the stuttering UNLESS you are manually setting the timings. In this case set the timings to "by SPD", "Auto", or "Failsafe".

            Originally posted by Salvage
            I can encode a DivX movie and play a new game at the same time and not notice the encoding is even happening.
            Multi-tasking is the biggest advantage of HT, and in many cases your scenario results hold true, but not many people would encode while gaming even with the ability to do so. If you do, then definitely leave HT enabled.
            No Linux, No Choice.
            Know Linux, Know Choice.

            Comment


            • #7
              Originally posted by LeatherMan
              but not many people would encode while gaming even with the ability to do so.
              I don't do things like that often, but I like the option that I can do it whenever I want. I even think it's worth the extra I paid for Intel over AMD.
              Hippopotomonstrosesquippedaliophobia, n. See also Irony.

              Comment


              • #8
                Originally posted by LeatherMan
                In your scenario the HyperX is guaranteed to run CL-3 at it's labeled speed (500) but should have no problem running CL-2 at the much slower speed (333). Even if it couldn't run CL-2 @ 333, then both sticks would be set to CL-3.

                Basically, it is impossible to run them at different timings so IMO this can't be the cause of the stuttering UNLESS you are manually setting the timings. In this case set the timings to "by SPD", "Auto", or "Failsafe".
                I knew that was true for the speed, but didnt know that was also the same about the CL number. Thanks for the info. and there is a slight hiccup with the mobo and my ram. For some reason in my Dad's computer the PNY 512MB DDR 333 RAM works normal and the mobo sees it as a DDR333, but when i first put it in my PC, it saw it as a DDR200 (100MHz) and that caused me many headaches till I figured that out, so I had to force it. So thats when I bought the Hyper X DDR500. now the mobo is only rated for 400 max but figured If I ever upgrade the mobo Ill be a step ahead, and it would run fine as 400. Well the mobo auto detected the HyperX as 333 (I expected it to see at least 400) But I left it and it worked fine. Then I forced it to 400 and it still worked fine. But then I got the idea with my PNY RAM that maybe there was a slight bios bug and I would just need to force my other RAM chip to 333 and so I tried that and it worked. So I combined the 2 chips, and thats when it started having this stutter, but I wasnt sure if it was the HT or the RAM. So then I tried my dads RAM plus my RAM in my PC, both PNY 512MB. And it works super smoothly now. Even better than the HyperX by itself. So I traded my Dad for his RAM and gave him my HyperX and we are all happy. Maybe there is some probllem with not using HyperX at its full speed. So since my mobo is rather new, maybe there will be a bios upgrade, (there has already been 3 on the website tho) But when I get a DDR500 mobo then Ill try my HyperX again and see if its any better. But for now, 2 512MB PNY DDR333's and its running beutifully(with forced DDR333). Maybe I will try to run a server on my PC now, I had the idea to run the server on one process of the HT and play on the other one. Since the current servers seem to hate me.

                Thanks for the help guys.

                EDIT - Nevermind, problem still exists. Tried to run a server on my PC then play on it and it causes the stutter. I even tried going back to the single HyperX chip, no good. I wonder if the next XP sp2 will fix this, or if its a problem with my mobo/processor. Maybe Ill buy intel board instead of SIS.

                Comment


                • #9
                  I recently built a PC for a pal of mine, and it displayed a "stutter" very similar to the one you descibed. After spending hours and hours trying to sort it out, it eventually turned out to be bad AGP drivers (or bios, or maybe even a bad AGP slot as we had the latest drivers)- despite the card and the board supporting it, at 8X the stutter was a regular occurance. Turning it down to 4X completely cured the problem.

                  I read somewhere that you only get around a 2% difference in performance (between 4X and 8X) on current graphics cards- we couldn't tell the difference, anyway (apart from the lack of stuttering).

                  Comment


                  • #10
                    Actually, I was getting a slight pause on occasion yesterday(caused by removing rage3d tweak).

                    What fixed it for me was uninstalling my video drivers, re-installing DirectX 9.0b, and re-installing my video drivers.
                    Hippopotomonstrosesquippedaliophobia, n. See also Irony.

                    Comment


                    • #11
                      I had a problem like this a while back. My games would pause for about 10 seconds every now and then after I updated my video drivers. Turns out I had to update my motherboard BIOS.
                      (AKA Dresden)
                      Despite all my rage, I am still just a dwarf in a cage.

                      Comment

                      Working...
                      X