No announcement yet.

Invisible gear and loadout

  • Filter
  • Time
  • Show
Clear All
new posts

  • Invisible gear and loadout

    I've finally got Thievery back on this computer and now I'm having a weird loadout problem. For a few weeks now I've been playing on Brodys server with no problems. Now I can't get in without my gear being invisible. I can draw water arrows and broadhead arrows and see those, but they don't have the attached viewfinder. I can hear the blackjack draw, and can knock out guards, but I can't see anything. All the potions and lockpicks that should be seen on the right are gone.

    I'm running the D3D 10 video driver and if I run a solo game everything shows.

  • #2
    Seems like its a video driver issue. I've switched video drivers from D3D 10 (which has worked fine for me before) and tried a few others like the Open GL and now I'm seeing all my gear again. Now the brightness slider doesnt work for me. Ever taff with a walking cane???


    • #3
      It could be something simple like the defaults being different for every renderer.

      Until someone adds bumpmap files to the texture folder, there is no advantage in using the DX10 renderer anyway. You will also get faster performance with DX9 or GL.

      Smiftsch has made newer renderers that may behave better, including XOpenGL OpenGL3 / OpenGL4


      • #4
        I'll check those out. I'm back to running D3D10 (I don't have a DX9 in my options yet). No invisible loadout issues now. The brightness slider works fine now. I think the issue was I bumped the resolution up to the point where my gear pushed out of view on the right. I noticed the better I had the resolution the more likely I was to have the gear descriptions clip and show on the right side of the screen and the left.

        Now the issue is I can't control the music, so some maps like Kings of the Desert have an overpowering sound effect that plays over and over that I can't turn off with the music slider. I've been switching off my speakers on maps like that for now. Most maps I don't have that problem.


        • #5
          I don't know the technical UnrealEd terms but this depends on if the music is 'music' in the Unreal sense or a general ambient sound effect on the map (like wind, or water trickling)

          In which case the music slider will do nothing.

          There is another way to solve it; Don't play the crap maps.
          -TuF- Emptying clan servers of their own clan members since 2010
          - Agg moderator campaign supporter 2011
          - #2 of 3 LANers of the Apocalypse!


          • #6
            Yeah the slider is all the way to the left but some maps the theme music that they build into areas just overpowers all the other sounds I'm looking for. I'm trying to find a way to switch off music from a config file or something so I don't have to switch my speakers off.


            • #7
              I haven't seen this topic before, so the answers may be late. The issue with missing hud has something to do with the FOV (I can't recall precisely atm), it was either AutoFOV property (I think it is supposed to be set to false) in renderer's settings (Th.Aux ini), or DesiredFOV and Default FOV in ThieveryUser.ini (both should be set to 90.0). I have heard people complaining on this issue, and in all cases it helped.

              The slider in options allows the music to be only a bit less loud - it was done on purpose in 1.7, to disallow you from taking advantage of having music turned off. I'm not fond of this feature to be honest, as the music at some levels (like DE) is terribly loud. It is still possible to turn it off in your ThAux ini, by setting MusicVolume property to 0 (slide allows just something like 96). I don't consider it unfair, and I guess most player wouldn't as well.

              edit: I looked for it a while and found properties DesiredFOV and DefaultFOV present in ThieveryMod.ini as well. What is more, they are set to 106.0 by default, which is incorrect in online gaming, and should be changed to 90.0. Most likely, there is no need to tweak with renderer's settings.


              • #8
                i tried the autofov fix (i have this same problem btw with *everything* except DX9 and Software :\) and xogl renderer has terribad performance (20~fps on a HD7850, but the oldunreal thread does mention specifically bad performance on pitcairn for some reason)

                and well, without autofov=false entire screen was black (except for skybox)

                fov settings in thaux and thieverymod are all set to 90.

                odd though, that i don't get this problem in a singleplayer local game...

                also, weirdly, going to windowed mode and back solves the problem (temporarily) and then it breaks again at some unspecified point, maybe after dying idk.
                Never, ever, argue with an idiot. They'll drag you down to their level and beat you with experience