Announcement

Collapse
No announcement yet.

Mixing different RAM

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mixing different RAM

    Hey, all. I can't find a few specific nuggets of info, so I thought I'd see if any of you knew. Pardon the density of the next paragraph, but almost all the info you need is in there.

    I'm having trouble with my RAM. My system was rock-stable before the upgrade. I just bought 2x1GB Corsair XMS CL 3-2 DDR400. I also already had 2x512MB Corsair XMS CL 2-3 DDR400. My mobo is a GA-7N400 Pro2, which has an nForce2 400MHz FSB. It has 4 DIMMs. I want to combine them all to get 3GB total memory (2x1GB + 2x512MB). However, I've since learned that my mobo will only take 6 memory banks and each stick has 2 memory banks. Ok, 3 sticks then. However, I BSOD on average once per 5 minutes when I install 2x1GB + 1x512MB = 2.5GB (in that order, first 3 DIMMs). The only thing different between the sticks is size and timing. From what I've read, mismatched size -- although not desireable -- should work. Mismatched timings I haven't heard a peep on. What I'd like to do is override the timings to match the slowest sticks (the 1GB sticks at CL 3-2), but I can't find this option in my bios. I tried upping the voltage on my RAM by +.2V but that did nothing. Oh yeah, my FSB is already underclocked and stable at 166MHz (it should be at 200MHz, but it was unstable when building it a year ago for some reason). Finally, my system appears to be 100% stable with 2x1GB = 2GB, but I want to use my 512's.

    A few more things. I don't know how dual-channel fits into this. Is this the same as two memory banks per stick? I've read people that inserted 4x512MB=2GB successfully. How does that work? Whatever dual-channel is, I really don't care if it's disabled. How do I disable it? I just want RAM capacity right now!

    In short: I want to mix differently-sized and differently-timed RAM. How? Thanks all!

    Here's a great resource that I've read and am versed in already: http://www.amdmb.com/article-display.php?ArticleID=279
    "Garlisk's got a lov-el-y bunch of coconuts."

  • #2
    Originally posted by Buho

    In short: I want to mix differently-sized and differently-timed RAM. How? Thanks all!
    I believe the size should add together but you will be limited to the slowest CL speed
    http://gladstone.uoregon.edu/~mbanes...summonslue.gif

    Comment


    • #3
      First, Why on earth should you need more than 2 gb of ram?

      Second, the slowest ram (timing) should go in the first slot then the machine will pick up that timing and it should work.

      Comment


      • #4
        The only problems with mismatched memory is that it's possible it decreases overall performance, that's probably not true though. From the vague opinions on the net if it does matter it's negligible.

        Both the other answers are correct AFAIK and I also had similar BSOD problems with my last two systems, I have my new one working corretly now but the old one needed the CPU FSB lowering and taking 500MHz off the clock speed because I could never fix it. From the sounds of it you're trying to run your RAM too fast, try putting the slowest chips in first and making sure that the overall system bus speed matches up. If not a +/- multiple to the RAM bus speed then it does cause performance hits and, in my experience, unstability.
        One of the three LANers of the Apocalypse!
        -
        The Unforgiven Casual Gaming Group - New Members Welcome

        Comment


        • #5
          Yeh thanks all. I'm still stuck at the same spot. I need to find how to change the timings in my bios. I already have the slower sticks in the first two slots. I'm thinking it should really be possible to do what I'm trying, so that gives me hope.
          "Garlisk's got a lov-el-y bunch of coconuts."

          Comment


          • #6
            Try looking for an 'Advanced Setup' or something similar, usually activated by pressing an F key on the main BIOS screen, I've know them quite well hidden before.

            I suppose it's possible you have a crap mobo which means you might have to switch some jumpers or it may even be all automatic and not possible to change. Check your mobo manual as well, the Advanced screens may be activated with a hidden key that you'll find in the manual to stop 'noobs' breaking the mobo...
            One of the three LANers of the Apocalypse!
            -
            The Unforgiven Casual Gaming Group - New Members Welcome

            Comment


            • #7
              My mobo is a Gigabyte GA-7N400 Pro2 with an nForce2 FSB. It's the best mobo I've had, and I think overclocker's prefer it too. I'll try the F thing (I'm at work now).
              "Garlisk's got a lov-el-y bunch of coconuts."

              Comment


              • #8
                Not sure about your board, but some BIOS have automatic and manual settings. You may need to change a setting to manual before the timing settings appear.
                Give some taffer fire, and you'll keep him warm for the night with one less reason to cause trouble for the master.
                Set a taffer on fire, and he will be warm for the rest of his life, and have no need to bother the master.

                Comment


                • #9
                  The instability you mention makes me think that the PSU is either cheap or underpowered, and adding any additional RAM is overloading your PSU (this may even be why your CPU can't run 200MHz fsb stable).

                  What power supply do you have? (model/wattage)
                  Do you have the 4-pin ATX 12V connector plugged into the mobo?
                  What are the complete specs of your system? (hard drive/s, optical drive/s, sound card, case fans, etc).

                  If you want to eliminate mixed RAM being the culprit, install one of each size stick (1x1GB + 1x512MB) and see if you have the same instability.

                  It's also possible that one (or both) of the 1GB sticks are bad, so I recommend running Memtest86 for a couple of hours each, one stick at a time.
                  No Linux, No Choice.
                  Know Linux, Know Choice.

                  Comment


                  • #10
                    As stated before, the two 1GB sticks were stable when installed together with no 512's installed.

                    I got them to work! F didn't work, but I found under Advanced, "System Performance" which was set to "Normal". I changed it to "Manual" and it unlocked another setting: "Memory Frequency". It was set to "By SPD". What's this mean? Other options were increments between 50% and 200% and "Auto". I'm not sure what Auto will do. I changed the setting from By SPD to 100%. I'm now running rock-stable with 2x1GB + 1x512MB = 2.5GB RAM!

                    Frustratingly, when I stick the other 512MB in the 4th DIMM (or order it 1GB, 512MB, 1GB, 512MB), my mobo ignores the 3rd and 4th DIMM! I'm thinking I can only get this to work if all four are identical sizes (and/or timings).

                    Thanks again for all your help, guys. Thanks Leatherman for being thorough. Thankfully it wasn't nescessary. I didn't get the timing settings I was looking for (set CL individually), but at least I made my mobo happy. You think you know your stuff until something like this happens!
                    "Garlisk's got a lov-el-y bunch of coconuts."

                    Comment

                    Working...
                    X