No announcement yet.

Stereo only sound for 4 speaker setup- Help!

  • Filter
  • Time
  • Show
Clear All
new posts

  • Stereo only sound for 4 speaker setup- Help!

    Hello All,

    First of all, let me state up front how much I love Thievery. Simply put, it's a masterpiece of design and execution.

    That said, I'm having difficulties with getting all 4 of my speakers to play the splendid sounds that help make Thievery what it is.

    What's strange is that my system works properly for another UT1999 total conversion known as Infiltration. There too, it's absolutely essential to be able to determine where the sounds are coming from.

    I have a Sound Blaster Audigy 2 soundcard. What should my in game settings be with my 4 speakers/1 subwoofer setup?

    Is there any advice you can give me in regards to enabling all 4 of my speakers to work? I'd greatly appreciate any assistance.


    April 9, 2006

  • #2
    I recall Mach saying that all you needed to do was have your windows setup configured properly.

    Thievery only supports quadrophonic (as opposed to 6 channel), so you may want to try setting up Windows as 4 speaker and then load Thievery.
    .:Mockers Thievery Guild:.
    - "until the cat is skinned"


    • #3
      Yep, 4 speakers only, worked a charm when I played, you could even look down and hear people above you (as the back of your in game head was facing up!) - turn your music off and sound up, learn to use the sound to your advantage and you've got a hell of a tool there.

      Quick reference :

      Start -> Settings -> Control Panel -> Sound Devices

      or in your volume control under advanced / properties.

      Oh, also in UT99, you disable surround and enable EAX, find a sound source in game, like a torch or waterfall and slowly turn your character in circles you should hear a definite difference.


      • #4
        Thanks for the advice!

        I tried the recommendations, and I'm still stuck with only my front two speakers working.

        Now, I looked through the sound settings in both UT99 and Thievery, and there's no option to enable "EAX". I'm assuming that I'm to enable the use of the "hardware" settings, yes?

        So, in summation, I've disabled the surround sound setting in both UT99 and Thievery, and I've enabled the use of sound hardware. My sound settings for the computer were already set to "Quadraphonic."

        Do you have any other recommendations for me to try? Again, the four speakers ARE working in Infilitration, so I'm a bit confused as to why it's not working in Thievery.

        Thank you!

        April 10, 2006


        • #5
          Hardware sound is the right option

          Odd that your not getting sound only in TUT, if I got sound in windows through media player then it would work in UT so not sure what to suggest.

          You mention it works in Infiltratration, why not check out the audio section of it's ini and comparing it with TUT's? If I get my computer set up again this evening I'll post here what mine is.


          • #6

            Thank you for your feedback. I discovered late last night that not only do my sound settings work for Infiltration, but also for plain ol' vanilla UT1999 (it's been years since I even started up the default game). For both UT99 and Infiltration, the sound settings are the same: all of the settings are maxed out in terms of quality, and I have hardware set to "on" as well as surround sound (even though I only have a quadraphonic setup, if i set Surround Sound to "off" my two rear speakers stop emitting sounds).

            I've made sure numerous times that Thievery has the exact same setup as UT99 and Infilitration, and yet I'm still only experiencing stereo sound.

            Should I do a completely fresh reinstall? Am I the only person to be suffering from this unusual bug?

            Thank you!

            April 11, 2006


            • #7
              I do remember some funnyness in the TUT sound department, sometimes it would give me odd sound or none. I'm sorry that I've not been able to help you so far :/

              Tonight I'll have my machine set-up again so I'll grab the settings and post them here for you, alternativy reinstalling could help.


              • #8
                Just an idle thought: Thievery 1.6 has a fix for a sound related bug. Possible that's causing the problem? (And probably not much to be done about it if it is )
                It's not my fault everything you like is terrible.


                • #9
                  I was finally able to get my quadrophonic setup to work. Here's how:

                  1. I opened up the ThAux config file.
                  2. I pasted in my sound settings from Infiltration. I presume that my sound settings from UT99 would've worked as well, since both Infiltration's and UT99's configs in regards to sound are identical.
                  3. I saved the changes to ThAux, and then...

                  I started up the game and Thievery's brilliant sound scheme was finally working in my favor!

                  But what a pain in the butt to get it working for my system!

                  Thank you all for your help on this one. It seems like a mighty strange and serious bug to have in a game where listening to the sounds are vitally critical. I hope that if anyone else has this problem in the future, that this thread will help.

                  Again, thank you!


                  April 12, 2006


                  • #10
                    Good work! Glad to hear your up and running


                    • #11
                      Originally posted by BiG_D
                      Just an idle thought: Thievery 1.6 has a fix for a sound related bug. Possible that's causing the problem? (And probably not much to be done about it if it is )
                      This problem was related to listen servers only.