Announcement

Collapse
No announcement yet.

Apache 2.2.3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Apache 2.2.3

    Hey, I just upgraded my server to Apache 2.2.3 and unlike Apache 2.0.59 it doesn't seem like it is listing directory contents correctly.

    Apache 2.2.3:
    http://spamslayer.homeip.net:8080/

    I want it to look like the directory listing on these pages:
    http://www.apache.org/dist/httpd/
    http://apache.mirrors.tds.net/directory/

    ya know? with the icons, last modified, size, desc., and at the bottom say what it normally says with apache 2.0.59: "Apache/2.2.3 PHP/5.2.0 Server at spamslayer.homeip.net on post 8080" or something like that.
    SSSSSPPPPPAAAAAMMMMM 44444 EEEEEVVVVVEEEEEAAAAA!!!!!

  • #2
    Option multiviews will do that for you. On my server I use "Options All Multiviews".

    I don't know what your configuration file looks like, pasting it to something like pastebin.cc would help.

    Comment


    • #3
      http://paste.biz/paste-157.html Wow, that site it cool ^^

      Originally posted by httpd.conf
      Options Indexes FollowSymLinks ExecCGI Includes
      So I think this is the line your talking about, if I change it, it should be: "Options All Multiviews" or "Options All Indexes FollowSymLinks ExecCGI Includes Multiviews"? ^^ thx for reply =D
      SSSSSPPPPPAAAAAMMMMM 44444 EEEEEVVVVVEEEEEAAAAA!!!!!

      Comment


      • #4
        Options All Multiviews, since All enables everything except Multiviews.

        Comment


        • #5
          Alright, I think I've done it right.

          New conf: http://paste.biz/paste-158.html

          But still the directory stuff isn't displayed right. Might be a problem with a conf file somewhere else?
          SSSSSPPPPPAAAAAMMMMM 44444 EEEEEVVVVVEEEEEAAAAA!!!!!

          Comment


          • #6
            Did you restart your server?

            Comment


            • #7
              I didn't restart my computer, but i restarted apache, unless I need to restart like MySQL and all that also..
              SSSSSPPPPPAAAAAMMMMM 44444 EEEEEVVVVVEEEEEAAAAA!!!!!

              Comment


              • #8
                Code:
                <Directory />
                    #Options FollowSymLinks
                    Options All MultiViews
                    AllowOverride None
                    Order deny,allow
                    Deny from all
                    Satisfy all
                </Directory>
                I'm not sure how it works on Windows, but I suggest you put in the whole filepath here.

                Comment


                • #9
                  Like this?
                  Code:
                  <Directory C:/Program Files/Apache Software Foundation/Apache2.2/htdocs/>
                      #Options FollowSymLinks
                      Options All MultiViews
                      AllowOverride None
                      Order deny,allow
                      Deny from all
                      Satisfy all
                  </Directory>
                  edit: doesn't work, the change above, some error about no multiple directories
                  SSSSSPPPPPAAAAAMMMMM 44444 EEEEEVVVVVEEEEEAAAAA!!!!!

                  Comment


                  • #10
                    You wrote the wrong kind of slashes, should've been;

                    Code:
                    <Directory C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\>

                    Comment


                    • #11
                      Code:
                      Syntax error on line 162 of C:/Program Files/Apache Software Foundation/Apache2.2/conf/httpd.conf:
                      Multiple <Directory> arguments not (yet) supported.
                      Note the errors or messages above, and press the <ESC> key to exit. 1...
                      SSSSSPPPPPAAAAAMMMMM 44444 EEEEEVVVVVEEEEEAAAAA!!!!!

                      Comment


                      • #12
                        I meant restart apache.

                        What's line 162?
                        You cannot nest directory arguments. Make sure there's no double ones or something.

                        Comment


                        • #13
                          Okay, I restarted Apache Cleared all my browser stuff and nothing changed.

                          Line 162:
                          Code:
                          <Directory C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\>
                          Maybe this?
                          http://directory.apache.org/
                          Nah..I don't know what it even is, haha.

                          I was searching around and read the changes list for once,
                          http://apache.reverse.net/pub/apache/httpd/CHANGES_2.2

                          *) mod_autoindex: Fix filename escaping with FancyIndexing disabled.
                          PR 38910. [Robby Griffin <rmg terc.edu>]
                          Think that has something to do with it?


                          EDIT:
                          Code:
                          # Fancy directory listings
                          #
                          #Include conf/extra/httpd-autoindex.conf
                          Uncommented this line. Now I get the icons and the <hr /> things, as well as Name, Last Modified, Size, Desc.

                          Looking to see where
                          Apache/2.2.3 PHP/5.2.0 Server at spamslayer.homeip.net on port 8080
                          is located, because I'm wanting to display that also.

                          MORE EDIT:
                          Code:
                          # Various default settings
                          #Include conf/extra/httpd-default.conf
                          Uncomment this line at the bottom of httpd.conf. Then under &#37;Apache2.2%\conf\extra there is a httpd-autoindex.conf file and a httpd-default.conf file.

                          In httpd-autoindex.conf:
                          Code:
                          IndexOptions FancyIndexing HTMLTable VersionSort
                          There is this line shown above, which I changed to read:
                          Code:
                          IndexOptions FancyIndexing FoldersFirst IgnoreClient SuppressColumnSorting VersionSort
                          Without that HTMLTable you get a little more spacing and the Name, Size, etc. isn't in bold letters taking up some room. This also puts all folders first, the Name, Last Modified are no longer links to change sorting stuff, and VersionSort sorts files if they have numbers, example: http://httpd.apache.org/docs/2.0/mod...ns.versionsort


                          In httpd-default.conf:
                          Code:
                          ServerSignature Off
                          Changed this line to say:
                          Code:
                          ServerSignature On
                          This shows the
                          Apache/2.2.3 (Win32) PHP/5.2.0 Server at spamslayer.homeip.net Port 8080
                          Thanks guys =]
                          Last edited by SpamSlayer; 3 Dec 2006, 11:33 AM.
                          SSSSSPPPPPAAAAAMMMMM 44444 EEEEEVVVVVEEEEEAAAAA!!!!!

                          Comment

                          Working...
                          X