Announcement

Collapse
No announcement yet.

Alpha Release - 2008/04/25

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alpha Release - 2008/04/25

    A new release is available from Nightblade's Testing Page. The changelog lists what has changed, but give a brief summary:

    - It is now possible to bind keys through the midgame menu (make sure you launch Nightblade with the launcher, otherwise UT3 will crash if you are playing Nightblade for the first time and you try to set the keys)
    - Started work on integrating Denny's new thief animations into Nightblade. At this stage the basic movement should work, as well as a frob animation, but there is no climb animation.
    - Marios now KO instead of kill.
    - Did some work on tag bolts, the bolts should no longer stick into rock (although the effect will stay). Also they should interact with water correctly.
    - Changed Nightblade so that Post Process Volumes in maps work again. Removed the NightVision and Invisibility desaturation effects for now.
    - Fixed a bug where guards were waking up crouched in netgames.
    Immortius' Forge

  • #2
    Fallen a bit out of the loop recently, but great work anyway.

    Comment


    • #3
      Originally posted by ChangeLog
      - Stopped blood splatter when hitting team mates.
      is this when TeamKill is set to false only?
      Speaking of blood splatter.. is it possible to add blood splatter to the sword or mace when hitting an enemy?
      Last edited by -KewlAzMe-; 25 Apr 2008, 12:16 PM.
      I'd Be More Apathetic... If I Wasn't So Lethargic

      Comment


      • #4
        Just went on a run to test things. Noticed some misses;

        Don't go to the bind window! I noticed that the bind list has duplicate entries for the controls, so it will bugg you about crucial actions not being bind, even if they are! (there's two entries for each action and you can't bind the same button to both duplicates, so you enter a loop where you can't exit the bind configuration screen because it tells you to bind the crucial action even if you can't)

        There's also a miss, mostly from my part, dealing with the AnimTree. I just noticed a value for animation blending between walking and running is wrong, so when you sneak the model will try to blend to run constantly and the player will look jerky. I'm on to fix this.

        So I ask not to feedback on weird animations as they haven't been sorted out correctly.

        Comment


        • #5
          Originally posted by Denny View Post
          Don't go to the bind window! I noticed that the bind list has duplicate entries for the controls, so it will bugg you about crucial actions not being bind, even if they are! (there's two entries for each action and you can't bind the same button to both duplicates, so you enter a loop where you can't exit the bind configuration screen because it tells you to bind the crucial action even if you can't)
          Sounds like the UT3 bug that does the same thing about Hoverboard not being bound, but it is.
          I'd Be More Apathetic... If I Wasn't So Lethargic

          Comment


          • #6
            No, I see it like this;

            Normal bind list
            Move Forward W
            Move Backward S
            Strafe Left A
            Strafe Right D

            As it appears for me
            Move Forward W
            Move Backward S
            Strafe Left A
            Strafe Right D
            Move Forward Not bound
            Move Backward Not bound
            Strafe Left Not bound
            Strafe Right Not bound

            In short, I need to bind all actions a second time to a unique key to even be able to exit the page. I shut it down the classic way (ctrl+alt+del).

            Comment


            • #7
              ahh i see what you mean
              I'd Be More Apathetic... If I Wasn't So Lethargic

              Comment


              • #8
                It might be something with local development files, but until Immortius has looked into it I think it's safest to say that people should be aware of the problem that it might appear.

                Comment


                • #9
                  I haven't been able to replicate this issue on my end. Can you check you UTGame.ini and make sure that the [Engine.UIDataStore_GameResource] section looks like this:

                  Code:
                  [Engine.UIDataStore_GameResource]
                  ElementProviderTypes=(ProviderTag="GameTypes",ProviderClassName="Engine.UIGameInfoSummary")
                  ElementProviderTypes=(ProviderTag="KeyBindings",ProviderClassName="UTGame.UTUIDataProvider_KeyBinding")
                  ElementProviderTypes=(ProviderTag="NBKeybindings",ProviderClassName="NightbladeMod.NBUIDataProvider_KeyBinding")
                  And check through the UTNightbladeMod.ini and make sure it doesn't have duplicate
                  [MoveForward NBUIDataProvider_KeyBinding] sections.

                  Thanks.
                  Immortius' Forge

                  Comment


                  • #10
                    Found it. ElementProviderTypes=(ProviderTag="NBKeybindings", ProviderClassName="NightbladeMod.NBUIDataProvider_ KeyBinding") Were duplicated, and the only difference were NBKeybindings as NbKeybindings.

                    Comment


                    • #11
                      Ok, I believe I know what caused that and I'll fix it for next alpha. It shouldn't be an issue most of the time though.
                      Immortius' Forge

                      Comment

                      Working...
                      X