Announcement

Collapse
No announcement yet.

Dynamic Shadows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dynamic Shadows

    Hey guys,
    Great mod, we got it working and played some. Afew weird things going on, but it was much more impressive than I was expecting and quite an enjoyable play.

    I was wondering if I could ask you something however. After launching Nightblade, I did some testing on my mod and noticed that my flashlight is now casting dynamic stencil shadows. I had someone else who's never played NB to change the UTEngine.ini settings you mentioned in your readme, and it didn't work. My thought was that they turned off stencil shadows and motion blur in UT3 for whatever reason, and changing .ini's does nothing to enable it.

    I had been trying to turn on stencil shadows myself but with no luck. Though my flashlight now looks kickass, I'm alittle worried what other settings you might of changed. Anyways, I was wondering if you could help me out and tell me how you enabled it exactly? Usually I wouldn't ask, but its odd since I now have it, but no one else does until they download your mod.

    I played around and everything else seems normal, but with no word on how to set up a TC exactly, conflicts or changes between mods are bound to happen.

    Thank you for any info you can provide, and good luck with NB.

  • #2
    It hasn't been turned off. You only need to add a light of the right type that forces dynamic shadows, there's nothing else to it. (and of course making meshes cast shadows) That's at least what I've noticed with UT3.

    Comment


    • #3
      Check out the Nightblade readme file. I'm pretty sure it lists the .ini changes made when you run the Nightblade launcher.

      Comment


      • #4
        Nightblade Launcher is set to activate and enhance the Dynamic Light settings. It creates a backup of the ini file when it does so (you should have a UTEngine.ini.bak in your Config directory). So at worst a diff should reveal what was changed

        I actually found some other settings that needed changing since I wrote the readme:

        Code:
        [Engine.GameEngine]
        AllowShadowVolumes=True
        ShadowVolumeLightRadiusThreshold=24
        ShadowVolumePrimitiveScreenSpacePercentageThreshold=0.0
        The launcher also makes an addition to UTGame.ini, although the mod will also make the change - a simple addition of Nightblade keybinds to the datastore. Unfortunately unless the game loads with the settings then trying to edit Nightblade's keybinds crashes UT3.

        I am looking forward to an actual TC framework so we can stop messing around with people's inis like this.
        Immortius' Forge

        Comment


        • #5
          So there were no changes anywhere else to enable the stencil shadows other than the UTEngine.ini settings that were stated in the readme? Like I said, I had a friend change those same settings in his .ini, and it didn't work. Very odd...

          Very thoughtful that you made backups of .ini's. I'm gunna mess around abit today, see if I can pinpoint exactly whats doing it.

          Comment


          • #6
            Originally posted by immortius View Post
            I actually found some other settings that needed changing since I wrote the readme:

            Code:
            [Engine.GameEngine]
            AllowShadowVolumes=True
            ShadowVolumeLightRadiusThreshold=24
            ShadowVolumePrimitiveScreenSpacePercentageThreshold=0.0
            ^ That isn't in the readme.
            Immortius' Forge

            Comment


            • #7
              Oh, my bad. I didn't see that that was in GameEngine. I got it working, with my old .ini. Thanks for your trouble, I won't bother you anymore .

              Comment

              Working...
              X