Announcement

Collapse
No announcement yet.

May 30th Alpha thoughts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • May 30th Alpha thoughts

    I'll sort this out later, just clearing my index card of notes:

    *Saw Tiernach, the guard outside the library stuck in seizure mode on the wall edge. A whack with a guard sword put him back in order, but only for a while. He seemed to be a bit off the ground.

    *I might be able to fix this with some video card settings, but there's now a weird, knee-high gray fog in the entrance and exit areas. I could see it through walls and didn't see this in earlier versions.

    *When shot, typo of pincushion as 'pincushin'. Nit-picking, I know

    *A KO'd guard, in this case, Arthour, who fell into the moat, woke up and walked along the bottom. He did eventually drown, but he walks totally unimpeded along the bottom.

    *How does the scarab alarm bug work for guards? That was quite a surprise!

    *Sword seizure- I assume this is intentional. You can't hold down the sword and attack. It's tap and release. I'm guessing this is to keep teammates from annoying you with constant hacking on you?

    *Silent eating? As a guard, you can eat cheese without making a sound. I'm guessing it's just not put in yet, or will guards eat stealthily???

    *4 bolts can open a door by damaging it, even if the door opens in the opposite direction it was shot from. I see a cheap way to open doors for camping, chicken guards (like me).

    *Hitting Escape and going to Audio, Input, or Player, my screens were blank except for "Initial Label Text" at the bottom. May be a one time issue on my end.

    *Nightblade launcher- I'm launching directly from UT3, not the nightblade launcher. If I try it, it brings up a dialogue box. Choosing the UT3.exe file doesn't work. It's looking for files of type UT3Engine ini. Am I missing out by not using the NB launcher? My load times are way slow.

  • #2
    Originally posted by SPIDER View Post
    *I might be able to fix this with some video card settings, but there's now a weird, knee-high gray fog in the entrance and exit areas. I could see it through walls and didn't see this in earlier versions.
    I added a ground-level fog volume to the exit areas (the entrance area is also an exit), you shouldn't be able to see it through walls though.

    *When shot, typo of pincushion as 'pincushin'. Nit-picking, I know
    I appreciate your attention to detail. Will be fixed next release

    *How does the scarab alarm bug work for guards? That was quite a surprise!
    Basically you place it on a wall, and if thieves make too much noise it will start clicking for a while, although it clicks occasionally anyway.

    *Sword seizure- I assume this is intentional. You can't hold down the sword and attack. It's tap and release. I'm guessing this is to keep teammates from annoying you with constant hacking on you?
    The sword actually works the same as in thievery - you hold it down, charge it and release when you are ready. The animation is just broken. If you charge it you will see that a different stroke is used though.

    *Silent eating? As a guard, you can eat cheese without making a sound. I'm guessing it's just not put in yet, or will guards eat stealthily???
    Not implemented yet.

    *Hitting Escape and going to Audio, Input, or Player, my screens were blank except for "Initial Label Text" at the bottom. May be a one time issue on my end.
    You need to use the launcher.

    *Nightblade launcher- I'm launching directly from UT3, not the nightblade launcher. If I try it, it brings up a dialogue box. Choosing the UT3.exe file doesn't work. It's looking for files of type UT3Engine ini. Am I missing out by not using the NB launcher? My load times are way slow.
    The launcher sets a number of ini settings (these are also listed in the readme.txt if you want to set them manually). Without the launcher the midgame menu won't work and the dynamic light and shadow effects won't be as good. It doesn't effect the load times - there will be a 5 minute load the first time you play DE unless you have downloaded the ShaderCache from the alpha page and installed it. The launcher will request the location of UTEngine.ini and UT3.exe files, although it should be able to find UTEngine.ini automatically if you have installed Nightblade correctly (the launcher should be in the UTGame directory in your "My Documents\My Games\Unreal Tournament 3" directory), and it may be able to find the executable automatically as well.
    Immortius' Forge

    Comment


    • #3
      Thanks for the very thorough response. You answer posts the same way I do, point by point.

      It seems the source of my troubles is the way I'm starting Nightblade, or quite possibly the way I've installed this whole thing (again). When I installed Unreal Tournament 3 I renamed the directory. I put it under C:\Unreal Tournament 3 etc. That being said, UT3 has a mind of its own and has put parts of it under Desktop\My Games\ and all that. I'm running searches on my computer to find ut3.exe and coming up with nothing.

      I *know* I had the NBlauncher working on my previous installation, but now for the life of me, I can't point it toward the ut3.exe. I've got the patch installed and I unzipped the Nightblade files to the specified directories. Last incarnation I had dropped each file one by one with other similar files.


      I suspect it's my stubborn installation of UT3 that's causing the problems. I'm going to go pull my hair out now.

      Comment


      • #4
        Originally posted by SPIDER View Post
        That being said, UT3 has a mind of its own and has put parts of it under Desktop\My Games\ and all that.
        This is standard and expected - all user content including mods should be somewhere in your My Documents\My Games\Unreal Tournament 3\ directory.

        I'm running searches on my computer to find ut3.exe and coming up with nothing.
        It should be in the Binaries directory under your Unreal Tournament 3 install directory, so C:\Unreal Tournament 3\Binaries\UT3.exe
        Last edited by immortius; 3rd Jun 2008, 04:13 AM.
        Immortius' Forge

        Comment


        • #5
          Just reading this thread has convinced me to get my ass in gear, I'm ordering UT3 when I get home tonight! I miss the testing
          One of the three LANers of the Apocalypse!
          -
          The Unforgiven Casual Gaming Group - New Members Welcome

          Comment


          • #6
            Glad my ineptitude has inspired a more competent tester to enter the mix

            The weird thing is, I can't see either the UT3.com or UT3.exe in the menu when I click on the Nightblade launcher. But if I go under my computer I can manually find it under Binaries. I'm just mystified why I can't get at these files the way I need to.

            So you don't think specifying my own folder for UT3 is the problem?

            Comment


            • #7
              It doesn't matter where you install UT3. The game will still make files under "My Documents" and that's the place where you have to unpack the NB (C:\Documents and Settings\*your user name*\My Documents\My Games\Unreal Tournament 3\UTGame).

              Comment


              • #8
                Hmm...I think I extracted Nightblade under UTGame instead. I know I didn't go through the C:\Documents and Settings path. I followed the Readme on that.

                Comment


                • #9
                  Originally posted by Readme
                  For Windows XP users:
                  To install Nightblade, extract the zip file to your \My Documents\My Games\Unreal Tournament 3\UTGame\ directory. Make sure the file path structure is extracted.
                  Immortius' Forge

                  Comment


                  • #10
                    On second thought, I didn't follow the read me, not exactly anyway. I read it but put it under UTGame in my self-made UT3 directory because I figured my situation would be different, since I created a new directory. I'm gonna un-install again now that I see UT3 isn't installing where I'm telling it to go. I can play Nightblade alright but I haven't been able to use the launcher in this incarnation.

                    Comment


                    • #11
                      IAH i'd rather put it in my UT3 folder if it is possible...
                      ...but apparrently it doesn't seem to work properly...
                      NTFS Junction Points to the Rescue.
                      Never, ever, argue with an idiot. They'll drag you down to their level and beat you with experience

                      Comment


                      • #12
                        Depending on how the UT3 mod framework pans out we may end up needing Nightblade installed to the main UT3 folder anyhow. I'll be reviewing this after the next UT3 patch.
                        Immortius' Forge

                        Comment


                        • #13
                          ^^ regarding that, I notice that the way Epic implemented the UCC batchexport command, you have to have the files in the main folder to export the uc files out of them. You can try to point to the my games area, but any supporting files it needs, it tends to look for them in the same path as the ut3.exe relative folders, which would be in the main install area, instead of also looking at the my games area. Perhaps this can be overridden by setting a working path before running it, but I haven't tried.
                          I'd Be More Apathetic... If I Wasn't So Lethargic

                          Comment


                          • #14
                            As long as the ModPackages of your UTEditor.ini are set correctly you can export UCs out of packages in the Unpublished\CookedPC directory using the UT3 Editor.

                            A lot of the commandlets do expect stuff to be in the main UT3 directory though, it is true.
                            Immortius' Forge

                            Comment

                            Working...
                            X