Announcement

Collapse
No announcement yet.

Lighting issues with UT2k3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lighting issues with UT2k3

    Ok, im rather new to ued3, but i think i've watched every movie at 3dbuzz and learned a lot, but lighting is slightly confusing me. I've read here that dynamic lighting isnt there, but I see a drop down menu in light properties that says dynamic lighting = true, what does this effect? Also, when i make a light, i check it out in dynamic lighting view, and it looks good, I do a build and it gets like very Black and white looking. but the light doesn't seem to light everything up properly. its like random shadows appear and the white parts are really white bright, yet right next to is completely dark and its all under the same light. but if I grab the light actor and move it slightly, the lighting looks perfect and natural. How do I get this perfect lighting to work ingame? when i play the map it goes to that nasty bright/black look.

    I notice in build options there are few lighting settings, either DXT1, DXT3, RGBB which should be set? DXT1 is default i believe

  • #2
    If a light actor is set to be dynamic it will not cast shadows/make a light map, and it will shine right through surfaces.

    If you want a lightmap/shadows you will have to make it non dynamic.

    The reason that it looks good if you move the light, is because the editor just do a quick guess at how a static light would look, but when you render it or play the map the dynamic light will kick in.

    Comment


    • #3
      It's not so much a lack of dynamic lights as a lack of dynamic lightmaps.
      Immortius' Forge

      Comment


      • #4
        Im running into this black spot problem, I guess it seems to be a known issue, and I've found some solutions on 3dbuzz site, but they dont really work for me. Anyone have any problems or solutions for this? if you dont know what i mean, Im referring to when you put "Add Light" on a wall and that wall goes completely black instead of lighting up. THe fix is to delete the light, rebuild and re-add, or to select surface properties, select UNLIT, rebuild, de-select unlit, rebuild. but i havent had luck with these solutions.

        Any suggestions?

        Also in Build options, should i change the lighting Format at all or leave default? havent noticed any changes either way.

        Comment


        • #5
          For this "problem" all i do is just make the light farther away from the wall/object and it seems to be fine for me (Not too far just far enough so it lights up the wall behind it)
          SSSSSPPPPPAAAAAMMMMM 44444 EEEEEVVVVVEEEEEAAAAA!!!!!

          Comment

          Working...
          X