No announcement yet.

Thievery Bug List

  • Filter
  • Time
  • Show
Clear All
new posts

  • Thievery Bug List

    What is it?
    I haven't seen such list anywhere. Since I have been active TUT player for a few years and I am most of the time in touch with game and thievery forums, I think I can handle creating and moderating such list.

    How is this going to work?
    You can post any bug you find in TUT and I will update the first post everytime you do. Some bugs will be marked as fixed when a new version, or a patch mutator is released.

    What for?
    Keeping all (or at least most of them) bugs in one place will make it far easier to Dalai, or other TUT developers to introduce new version with as few bugs as possible. I will also try to make fixes to some bugs and in the future put them into one mutator.

    The list:
    • Rope bug - Thievery 1.7 introduced some changes in the way player moves along ropes and ladders. I bet it had something to do with the hook. Now it seems you cannot move horizontally while attached to rope/ladder, unless you move vertically at the same time, getting of the rope is also very difficult (especially when you try to jump of it to some place like beam, shelf etc.). The worst is, that if you (or anyone else) pick up the rope while attached to it, you won't fall down, but get stuck instead.
      To reproduce: try detaching from the rope while not moving, or pick the rope up while attached to it.
      UNOFFICIAL FIX: ThHaxers171Fixes (see link below) Everything seems to work as in 1.6
      Originally posted by Vigilant View Post
      apparently you can get unstuck from the rope bug by shooting the hook above you.
    • Crossbow bug - There used to be a bug that allowed firing bolts faster than you are allowed to, a fix for it in 1.5 or 1.6 opened another bug that allows you to shot a bolt in certain situations, but it just consumes your ammo. More info:
      To reproduce: shoot the last bolt of certain ammo type, then quickly switch to other type and press fire
      UNOFFICIAL FIX: ThHaxers171Fixes (see link below) The fix is just partial for now, the animation of shot is still present, but you DO NOT loose ammo.
    • Bow bug - First occurred in ProMod. If you shoot the last arrow of a kind, and in a short time change into other arrow type and press fire, nothing will happen, what is more, if you manage to pull the bow by holding fire for the second time, then after shooting an arrow you won't be able to pull it back again for a while. It is especially annoying when you crack a guard in vent (with last crack arrow) and want to quickly finish him off with broadheads and your bow doesn't pull.
      To reproduce: In online mode, shoot the last arrow of certain ammo type, then quickly switch to other type and press fire. This will bug the weapon, and only putting it down and up again can help.
      UNOFFICIAL FIX: ThHaxers171Fixes (see link below) The fix seems to be solid and doesn't cause any side effects
    • Torch relight bug - the reason of >95% of server crashes. AI attempts to relight a torch, thinks he can reach it, but he can't and tries again, and again, and again... There are many maps having torches that are a bit too high (tests I performed showed that the critical value is 156uu above the ground). Some of them are Asylum, Theatre and Spider
      To reproduce: play standard version of Asylum as a thief, extinguish the torch between the spiral stairs and crematory and make guard relight it (you can spawn one with console command 'summon TGuard'). The game will freeze. And so does the server when it happens online.
      UNOFFICIAL FIX: ThHaxers171Fixes (see link below) Bots won't take care of torches that are too high for them.
    • Spectator Mode Crash
      Originally posted by Edy94 in Thievery 1.7.1 thread View Post
      I thought at first that it was random but it already happened 3 times. After i join spec and try to switch the spec mode, i get this error
      To reproduce: join spectator and play a bit with changing players you follow and/or spectating mode. Sooner or later it will crash.
      I have recently found out, that the game crashes if you press anywhere outside the buttons in speech/vote menu.
    • No Clear Item in preferences
      Originally posted by Vigilant View Post
      there is no "clear items" key to bind in the preferences!
      TIP: I know most of players know about it, but if someone wanted to have 'ClearItem' bound to some key, you can do it via your user ini file (ThieveryUser.ini in your UnrealTournament/System folder). You will have to assign ClientNoItem to some key, for instance: Ctrl=ClientNoItem. Alternatively you can do it in-game by typing set input [keyname] ClientNoItem, for instance: set input Ctrl ClientNoItem
    • Hook isssues
      Originally posted by Vigilant View Post
      getting off the hook is fairly annoying and sometimes really buggy (getting stuck etc.)
      You can get stuck if you combine using hook with movers.
      To reproduce:Play Aquatone and go up with the elevator. While standing on the lift, order lift to go down and as soon as you press the button, use hook. Try detaching after a while - it will lower you just to the height where you fired the hook. From there you will need to drop the hook to detach.
    • Fire button pressed after respawn
      Sometimes when you respawn (noticed it just when playing as a guard) you will have the fire button pressed after buying loadout, and your mace/sword will start to charge without you pressing the fire button, or - which is more annoying - your bolts may be automatically shot after switching to crossbow.
      To reproduce: play any map as a guard, get killed then respawn
      UNOFFICIAL FIX: ThHaxers171Fixes (see link below) Issue fixed.
    • Client travel crash
      Obviously everybody knows about this bug, as far as I could find out it has been in TUT since its first versions - for unknown reason clients occasionally crash during mapswitch on server.
      To reproduce: happens randomly once a few rounds (as far as I know for some more, for some less often)
      DEV TIP: I found some info on this bug in here: Unreal Wiki - it seems that most likely there is an unhandled reference to Actor derived object in non-Actor derived object that causes the level to be improperly garbage collected (most likely it isn't gced at all), which leads to crash during map switch, because of loading 2 different levels at once.
    • Key drop bug
      This one has also been in previous versions. I don't know what stands behind this bug, but it seems to happen just on DE (perhaps a few others map as well). With this bug you can copy keys, or sometimes it can lead to erasing your equipment (including Loki's Book of Enlightenment). I have checked what differs the key at DE and Grange_TME's UWW key that seems to work fine, and it seems it is just the way the key is placed - at Grange it is ThPickupSilverKey placed by the mapper, at DE the key is spawned by ThLootSpawnerMaster, it's class is custom, derives from ThPickupSilverKey and all it modifies it's the display name in HUD and keyTag. Perhaps one day I will do some deeper research into it.
      To reproduce: Pickup bookhouse key and drop it to the ground - you will see that it is still in your inventory if you use the inventory wheel. If you try selecting it, an action resembling ClientNoItem occurs.
    • Master Server
      The game's default masterserver is GameSpy, which is permanently down, and therefore you cannot browse servers unless you perform a few ini changes.
      To reproduce:Select 'Find internet games' and pick any of gametabs
    • No loadout menu when game starts
      Today Brody told me about a bug that he has been getting from time to time. The problem is that sometimes you den't get the loadout window after the game starts, so you cannot buy any item or loadout and have to play with default equipment. I have never experienced it before, but I took a look into the code and found the reason for that. It looks like pressing frob button while the game is about to start causes this unexpected behaviour. Setting "Force buying" in player setup does not fix this issue.
      To reproduce: Join a server or start new multiplayer game. Join thieves or guards. Press frob button while the countdown is going down. You won't get the loadout menu, game will automatically make you play.
      UNOFFICIAL FIX: ThHaxers171Fixes (see link below) Issue fixed.
    • Supply chest eats your ammo
      I got a report from SheriffBrawn, that the supply chest sets your standard bolts ammocount to 5, even if you have more than 5 bolts. It doesn't occur if you have more that 10 bolts.
      To reproduce: Have >5 and <10 bolts and resupply.
      UNOFFICIAL FIX: ThHaxers171Fixes (see link below) Issue fixed.
    • Loot respawn bug
      It's been in TUT for a long while, sometimes the loot doesn't respawn - I believe it is happening just at SkeltstonHead, however I could've seen it on HighwayInn (I'm not sure).
      To reproduce: No idea. It just happens randomly, the highest chances of getting it are at skelly. I don't think it ever happened in solo game.
    • Game crashes very often when minimized
      It's an issue present since 1.7 - the game crashes very often after switching back from minimized mode. I don't know if it is renderer specific or not. I know, that other players also experienced this issue (I think Getty did). I will try to attach a screenshot with error message the nest time it happens to me.
      To reproduce: Try minimizing the game and switch back into the game after a while (I think the longer you stay minimized, the higher are the chances of a crash).
    • Crossbow glow effect is broken
      Most likely it has something to do with changes in weapon numbers (all melee weapons were merged into one bind), and all ranged ammo index changed by -1. As a result, tag bolts do not cause the crossbow to glow in blue - in turn para bolts now do.
      To reproduce: Select a para bolt and see it is glowing blue.
      UNOFFICIAL FIX: ThHaxers171Fixes (see link below) Issue fixed for both tagbolts and firebolts.

    Fix mutator:
    Last edited by Przemek557; 31 Dec 2016, 06:04 AM.

  • #2
    Sometimes when you join an already started game and try to switch from free-cam to spec or something like that, it will crash.
    Last edited by Edy94; 1 Sep 2014, 10:16 AM.
    GettysTube - Indie games news and videos!
    UE4 Stuff channel


    • #3
      unlike as advertised, breath potions do not allow you to walk through crack
      Never, ever, argue with an idiot. They'll drag you down to their level and beat you with experience


      • #4
        Originally posted by necros View Post
        unlike as advertised, breath potions do not allow you to walk through crack
        As far as I know only some of ProMod features are enabled in Thievery 1.7 by default. Rest of them is up to server admin, configurable via ThieveryProMod.ini - there is parameter bBreathPotionsGiveCrackImmunity, and it defaults to False.


        • #5
          A few random things that I noticed:

          - there is no "clear items" key to bind in the preferences!

          - alt tabbing will cause timeout from the server and when you tab back in you have to reconnect :/

          - apparently you can get unstuck from the rope bug by shooting the hook above you.

          - getting off the hook is fairly annoying and sometimes really buggy (getting stuck etc.)
          Play Amnesia, get insomnia.
          aka. .:m.grimmy:.


          • #6
            Thanks, I have added the things you posted - except from that alt-tabbing issue - I am not sure if it isn't just UnrealEngine related, or even certain renders related (I have tried alt-tabbing today @Brodys and it worked fine, I didn't get disconnected).

            I have also added another bug (the fire button pressed after respawning). I bet this is why 2 weeks ago Brody started shooting firebolts everywhere near Aqua's lift xD. I have removed 5 of those bugs and put them into one package, I will post more info soon.

            There is also one more thing that has been bothering me - since TUT 1.7 I have been having some mouse issues in game menu (sometimes it gets stuck in top-left corner after launching the game, alt-tabbing helps, sometimes it moves faster in one direction than in another) I wonder if any of you also experienced it (meaning this is a bug ), or is it just me...


            • #7
              Thanks, when it comes to those "hook issues" guess i'm gonna have to do some more testing to pin point the problems.

              Not sure about the mouse problems, never encountered the "stuck in top left corner" issue, but slight acceleration when turning maybe, but nothing that would be too annoying to play
              Play Amnesia, get insomnia.
              aka. .:m.grimmy:.


              • #8
                I have updated the first message with 3 bugs, I have been also doing some small changes from time to time, you may see the changelog HERE

                edit: On the other hand, I'm not sure if you will have an access to that link,so to cut it short: supply chest, loot respawn and minimize crash.


                • #9
                  Also on Loki's Darkened Enlightenment, if you KO a guard after you get the book, the book is lost. It's happened to me twice and it doesn't appear to return to the bookhouse. I usually jump into the water to lose the blue glow after I get the book, so I don't know if it's any better if you're dry when you do this.


                  • #10
                    Updated the first post - no new bugs, but I just marked 2 of them(supply chest and crossbow glow) as fixed in my fixes mutator.


                    • #11
                      Looked at the key bug earlier today both with the old and new inventory wheel.

                      I see that for the new style wheel there's a delay between dropping/picking it up and it eventually appears (multiple times) in the inventory.

                      With the old style wheel then it's there instantly, but only if you use the previous item bind. If you use the next item bind then it never shows up at all, even though it is in your inventory.

                      As to the hook, a hacky fix I guess would be to (in code) on the detach function:

                      Get the starting location when fired - on detach from hook check the player location against it - when at this point then drop the hook (make it hidden)- destroy the dropped hook - add a new hook to the owners inventory - set the new hook to the current item.

                      Should be so quick no one would notice or just trace from the player to solid ground and keep winching down till they're on the ground.

                      Is it a bug that you can buy 6 spider hooks? Seems excessive.
                      [E.D.G] "Eaves Droppers Guild - we're on the edge."

                      All New Thievery-O's!