Announcement

Collapse
No announcement yet.

WebAdmin problems...need help.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • WebAdmin problems...need help.

    Ok, the problem is this. The server is set up on a LAN and people connect to it over the internet via the router. This works fine. The webadmin alos works fine...if you access it over the LAN.

    What doesn't work is when anyone tries to connect to it over the internet. The webadmin redirects you to the servers ip address...which is 10.0.0.1.

    Can anyone help?

    (BTW, everything IS set up ok. It's a problem with the webadmin itself).
    One of the three LANers of the Apocalypse!
    -
    The Unforgiven Casual Gaming Group - New Members Welcome

  • #2
    Originally posted by Chainsaws
    Ok, the problem is this. The server is set up on a LAN and people connect to it over the internet via the router. This works fine. The webadmin alos works fine...if you access it over the LAN.

    What doesn't work is when anyone tries to connect to it over the internet. The webadmin redirects you to the servers ip address...which is 10.0.0.1.

    Can anyone help?

    (BTW, everything IS set up ok. It's a problem with the webadmin itself).
    If it wasn't what I mentioned in the other thread, I'm stumped, though I seriously doubt it's a problem with webadmin itself, if it works over the LAN connection.

    Only other thing I can suggest is to send me your thaux.ini file and I can have a look through it, see if there's anything you've missed. Keeping in mind, of course, that that file has the admin and webadmin passwords stored in it.

    Comment


    • #3
      Microwave seems to think it's something the webadmin server is doing....I can always have a look through the ini files meself, I'd probably be able to spot anything suspicious, but I'd rather not have to waste a whole evening on it :grin:

      I imagine its some setting that's written into the serveradmin code which would need some kind of patch to fix rather than a setting in an ini file. Thanks for the offer though..
      One of the three LANers of the Apocalypse!
      -
      The Unforgiven Casual Gaming Group - New Members Welcome

      Comment


      • #4
        Open up your ThAux.ini file and under the [UWeb.Webserver] section make sure you have the following line

        ServerName=<your WAN ip address>

        I suspect this is the problem.

        Comment


        • #5
          That was just the ticket! Thanks Grank!
          One of the three LANers of the Apocalypse!
          -
          The Unforgiven Casual Gaming Group - New Members Welcome

          Comment


          • #6
            just for the protocol, that idead didnt work for me.

            so i did that:

            the default port is 80. i got an webserver running, that uses that port too. so i switched in thaux.ini the port for webadmin to 90.

            thats it.

            now i type http://123.456.789.123:90/serveradmin . im in !!!.

            so for probs coming forward, u got that helping way too.

            brody
            A real huge Man will neither stamp on a Worm, nor crawl for an Emperor

            Thievery Customs Center
            Vietcong Customs Center

            Comment

            Working...
            X