No announcement yet.

Mesh import

  • Filter
  • Time
  • Show
Clear All
new posts

  • Mesh import

    Fisrt of all, this is the first time I've ever tried to import other content into a package, and I know virtually sod all about scripting. What am I doing wrong, and how am I supposed to do it?

    I need a shield class that has pitch of 16320. Subclasses don't inherit pitch, roll or yaw from the default properties, meaning that when the present shield class (a subclass of ThPickupObjectiveItem) I have is dropped, it sticks in the ground edge on. I need it to lie on the ground face up.

    Attempt 1: Wotgreal

    So I exported the mesh in TheiveryMod.u using a version of Wotgreal (Wotgreal 2510 full). I now have a .3ds, _a.3d, & _d.3d. Wotgreal is nigh-unusable on my system because of a text display error, and when I tried to compile a LeoShield package it did absolutely nothing.

    Attempt 2: VUC++

    Can't compile due to not having other Thievery Packages loaded, it seems. Add all Thievery packages to standard edit packages.

    VUC++ Demands to export and recompile all TheiveryUT packages, does so. Exits due to errors several times before getting to my Shield package. Demands to export all sounds, models etc before I can recompile anything more. Reinstall Theivery after I fuck nearly every package up with VUC++.

    Attempt 3: UED

    It compiles the package ok, with the class LeopoldShield visible in the actor tree, but will not import the model. This is the code I'm using:

    // LeoShield.LeopoldShield
    // ================================================== ==========

    class LeopoldShield expands ThPickupObjectiveItem;

    #exec MESH IMPORT MESH=LRoundShield ANIVFILE=MODELS\LRoundShield_a.3d DATAFILE=MODELS\LRoundShield_d.3d X=0 Y=0 Z=0
    #exec MESH ORIGIN MESH=LRoundShield X=0 Y=0 Z=0 PITCH=16320


    #exec MESHMAP NEW MESHMAP=LRoundShield MESH=LRoundShield
    #exec MESHMAP SCALE MESHMAP=LRoundShield X=0.1 Y=0.1 Z=0.2


    Yes, I have renamed the shield mesh so it correlates with the way I've renamed it in those import statements, same case, etc. Of course, from UED it won't let me input the mesh in default properties, because it isn't there! :x

  • #2
    UEd is great for all your scripting needs, but if there's one thing you can't do in UEd, it's importing files. UEd just ignores all the #exec commands completeley.
    Here's the tutorial you need.


    • #3
      Thank you, UCC makes sense to me and I've made a bit of progress with it. However, if I leave all of the Theivery .u files out of the standard UnrealTournament.ini edit packages, UCC exits because it can't find the parent class. If I put them in, it tries to recompile TheiveryMod.u and fails dues to a lack of textures, etc.

      I'm also pretty sure recompiling TheiveryMod.u isn't a good idea... That would change the GUID, would it not?

      I'll try to work around it by making a decoration subclass, placing one in my map, then leeching properties from it with a subclass of ThObjectiveItem made in UED. Nonetheless, any idea why UCC is trying to recompile a .u that's already there?


      • #4
        Yes, you don't want to be recompiling ThieveryMod.u. Jered used to have this problem too, I think it was down to misordered or misspelt entries in the editpackages lines... make sure you're spelling ThieveryMod.u properly.


        • #5
          Hmm, I copied and pasted from ThAux.ini

          Thanks for your help, both of you. The workaround seems to be fine, so far.


          • #6
            Shame the model isn't a .psk.. then you could just import it using ut2k3's UEd. Still, you could MAKE it a psk by importing that _d.3d into Milkshape and reexporting.. (might need to take it over to 3ds max and export using actorx though). Hmm, sounds like overkill.