Announcement

Collapse
No announcement yet.

Elevator Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Elevator Problems

    Okay, I got this elevator that moves to (so far) 4 different floors. I think I've got everything set correctly except there are 2 problems:
    1) Whenever the elevator is activated it makes a hell of a racket after I've pressed the button, any button. Sounds like a machinegun firing only with the button switch sound 'ratatataing'. The sound is even there when I have no sounds in 'moversounds'.
    2) My buttons keep sliding off the elevator and hover in mid-air in the elevator shaft. I've got the 'attachtags' set correctly, but this still happens - though not all the time, only when I've used it alot. (usually after about 3 or 4 activations)
    3) Now, erm, here's the thing. I used the 'elevator mover' to create the thing. When I intersected should I have intersected and 'polyed to brush' with the buttons already on the mover template, or should they have been added later after intersection? I always add my door handles after intersection and what not, but I recently read a tut on elevator making that suggested intersecting with the buttons?
    4) I think I might have made a no-no as well: I used T-buttons and T-elevator triggers on a elevator mover which I think is UT - is this the root of the problem? And would creating my own buttons solve all these problems in one swoop?

    Other than the above, the elevator moves fine to each separate floor and can be called to each floor from that floor. Though I guess there is no way to stop the elevator from stopping at all the floors in between 1 and 4 when I just want to go directly to 4? At present it stops at each floor no matter where I want to go then continues on its way to its destination. (yay...heh)
    ...and all is silent, save the voice of the clock...

  • #2
    I'd try using the UT triggers for the mover, but I have no idea...
    I'm sure you've probably read this already, but it might be worth another look: Lode's Elevator Tutorial
    It's not my fault everything you like is terrible.

    Comment


    • #3
      Originally posted by SiLeNt_NiGhT
      2) My buttons keep sliding off the elevator and hover in mid-air in the elevator shaft. I've got the 'attachtags' set correctly, but this still happens - though not all the time, only when I've used it alot. (usually after about 3 or 4 activations)
      Am I understanding then that the buttons are part of the elevator cage that moves up and down? If so, maybe a solution would be to have 4 stationary buttons not part of the elevator at each floor. You see elevators in Thief like this a lot. Each button, of course, corresponds to a floor and pressing the button takes the elevator to that floor. That way, you don't have to worry about moving buttons at all.

      Comment


      • #4
        Big_D,
        Thanks, man. I've looked over Lodes tut and I think I'm gonna replace all the buttons and triggers with UT types and see what happens.

        LR,
        That's a great idea! Never occured to me. Yes, I have the buttons moving with the elevator cage itself. And I have one button at each floor to 'call' the elevator to that floor. If after I try replacing all the buttons and triggers as I said above to Big_D, and if that doesn't work - I'll try your idea. Thanks!!
        ...and all is silent, save the voice of the clock...

        Comment


        • #5
          Wow, hey nice in here.
          Just thought I would add that having buttons on the wall (IE not moving with lift) has to be done carefuly so people can't get killed by being under/close to the button when the lift moves, see Asylum:
          When on the lower floor in the middle of lift with body on the wall, you come up under the button and get squished.

          *wonders off again*
          How TuF are you?
          League of Legends
          Bloodbowl by Extensions

          Comment


          • #6
            Well, I've managed to fix everything but only through LR's suggestion - keeping the buttons off the elevator and on each respective floor. My elevator is no ordinary design, perhaps that was the cause... ah well.

            Thanks LR, for that idea.

            Check the screeny I added, #7, at DP's site. You'll see perhaps why I was having problems. If it isn't up yet it should be up soon.
            ...and all is silent, save the voice of the clock...

            Comment


            • #7
              Nice work, shame you could't get those buttons on the lift after seeing that pic, you would of had a great design on it, nm though its looking great now too, hehe.
              How TuF are you?
              League of Legends
              Bloodbowl by Extensions

              Comment

              Working...
              X