Announcement

Collapse
No announcement yet.

Help! Dissappearing brushes.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help! Dissappearing brushes.

    I created a room/hallway with a number of rectangular amd cylinder shaped brushes, and into this room I added some chains hanging from the ceiling. I used the volumetric shape and then added the shape using the builder brush. Is this correct or should I have used special brushes, as one of the volumetric brushes has caused some problems it seems.
    After saving this mission a number of times, and building and playing it without any problems whatsoever, I started UnrealEd up today to find that in the last few saved copies of my mission most of the brushes in the room I was decribing have dissappeared! The volumetric brushes in that room are still there, but when I try deleting them, all but one are removed, whilst one cannot be altered or deleted it seems. Does anybody know what caused this, and how I can fix it.
    Thanks.
    I am *NOT* Michael Jackson.

  • #2
    Tried a reboot?

    Comment


    • #3
      Maybe it's all that pixie dust you've been using lately.

      This may have something to do with the brush order(timing).
      Hippopotomonstrosesquippedaliophobia, n. See also Irony.

      Comment


      • #4
        No no, the pixie dust makes me see things, it doesn't make things dissappear.
        I tried a reboot, but that didn't help.

        Here are two pictures, one of an earlier version and one that shows what has happened to about five previous saved versions, despite the fact that they were fine after a build (this has corrupted a number of versions).

        If my understanding is correct, that would rule out an order/timing issue as the brushes would still appear in the editor.
        I'd also like to know how to delete that volumetric brush that was in the same room if thats possible.

        Thanks.
        I am *NOT* Michael Jackson.

        Comment


        • #5
          this could be buggy copy & paste functionality in ued - sometimes it fails to track correctly unique names of the objects and objects with the same name are created - usually the map becomes corrupted at this point.

          if you can select the brush, try using the 'delete' command from commandline/log window

          Comment


          • #6
            Try selecting them with Ctrl+Alt drag. If you get anything, make sure it's got it's Advanced>bHiddenEd set to True.

            Try hitting the "Unhide All"-button.

            It's a longshot, but it might work.

            Maybe you've accidently selected it when deleting something else? Done that... :roll:

            Comment


            • #7
              Thanks for all the help. I had selected a number of brushes and copied them to save time, so as Switch said it was probably that the brushes didn't have unique names so the copied ones dissappeared. I just carried on working from an earlier version, I just hope this doesn't happen often.
              Thanks again.
              I am *NOT* Michael Jackson.

              Comment

              Working...
              X